Search found 30 matches

by Copper280z
Mon Sep 09, 2019 11:30 pm
Forum: RaceCapture App Operation and General Q&A
Topic: Ubuntu - Unable to connect to RaceCapture MK2
Replies: 4
Views: 2651

I just solved this myself. It's likely that you need to add your user to the dialout group to get access to the serial port.
by Copper280z
Mon Sep 09, 2019 10:55 pm
Forum: RaceCapture App Bug Reporting / Feature Requests
Topic: Linux dev install and connecting to RCP/mk2
Replies: 1
Views: 985

Looks like it was a permissions issue, even though my user is in the dialout group.

Code: Select all

sudo chmod 666 /dev/ttyACM0
This fixed it for me and now I can talk to the RCP!

Edit, adding my user to the dialout group did work, I just forgot to log out and back in after.
by Copper280z
Mon Sep 09, 2019 8:59 pm
Forum: RaceCapture App Bug Reporting / Feature Requests
Topic: Linux dev install and connecting to RCP/mk2
Replies: 1
Views: 985

Linux dev install and connecting to RCP/mk2

Due to a series of events, and a serious ass kicking at Solo Nationals, I'd like to get the datalogger updated and reinstalled in the racecar. The only PC I have available is my ubuntu 18.04 laptop, and I'm not really much of a pro at it. I managed to get the source to execute, though I had to use a...
by Copper280z
Mon Jul 06, 2015 9:32 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14130

I've got it to work without the Lua script, but the steering and throttle position data(which I get via CAN) is 70% of what I'm interested in.

I've been meaning to try another SD card, but haven't yet. I'd love to see another configuration, especially if it works with a script.
by Copper280z
Thu Jul 02, 2015 4:55 pm
Forum: RaceCapture/Pro General Q&A
Topic: Haltech Elite CAN data streaming to RCP 2?
Replies: 5
Views: 4886

Assuming haltech complies with the CAN standards and gives you a definition of how they send the data, it should be quite straightforward. If they don't give you a definition of their data stream, you'll be in the same boat trying to decode it like those of us reading an oem canbus.
by Copper280z
Tue Jun 30, 2015 2:03 am
Forum: RaceCapture/Pro General Q&A
Topic: what to do with data on sd card
Replies: 1
Views: 2457

Read through this thread, the AEM/GEMS software is pretty good, even if it's kind of a pain to get the data into it.

http://www.autosportlabs.org/viewtopic.php?t=3731
by Copper280z
Tue Jun 30, 2015 1:04 am
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14130

Hey Brent, any updates on this? It's been a few weeks now and several races where I'd really like to have run data have passed. As it sits the RCP is pretty much useless to me.

Any advice on how to get it to work somewhat reliably? Revert firmware back a ways? Different SD card?
by Copper280z
Mon Jun 15, 2015 7:21 pm
Forum: RaceCapture/Pro General Q&A
Topic: Displaying CAN data in realtime
Replies: 0
Views: 2245

Displaying CAN data in realtime

I wrote a relatively simple script to display CAN data in realtime from the serial port of the RCP, thought it might be useful here. The lua script the RCP has loaded is just printing CAN data like : "ID, byte, byte, byte, ...". I believe there's an example script that does this in the wiki somewher...
by Copper280z
Fri Jun 12, 2015 5:56 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14130

Got a chance to play with this some. Updated to 2.8.2 and 1.3.4 app. Starting logging with the button, at first I could not get any data out of it. Terminal output: Logging started Open: rc_14.log file: close *Wait several seconds and hit button again* Logging stopped Logging: wrote 0 *Wait ...
by Copper280z
Wed May 27, 2015 11:20 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14130

In my case, I was powered on the entire time the logs were collected (RCP powered through the OBD connection). It stays powered on whenever connected to the OBD port, even if the car is off. I've been using the same micro SD card from the beginning. 32gb class 10 SanDisk ultra card. I didn't see th...
by Copper280z
Fri May 22, 2015 7:45 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14130

I don't have detailed info on when the log was started or stopped, but I'm pretty confident that it's not resetting due to voltage sag on start. In one case I have a log that ends several turns into a run. I will be sure to start the log only after the engine is running at the next event. I do know ...
by Copper280z
Fri May 22, 2015 6:47 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14130

Right now I'm triggering the logging with the button, nothing in the script should be triggering it. Here is the script: --500K baud. set your baud rate here. initCAN(0, 500000) setTickRate(30) --onTick() will be called at 30Hz. steering = addChannel("Steering",50...
by Copper280z
Wed May 13, 2015 10:40 am
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14130

Used the RCP at the NJ Prosolo, data looked a lot like what I pictured above, most of it missing.
by Copper280z
Tue May 05, 2015 2:26 am
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14130

Missing data, no explanation why

I've had 2 autocrosses so far this year. So far I've only gotten data for about half of the runs I've taken. Most times a file is created, but it has no data, or it's cut off after some period of time. I'm not seeing the error light on after a run at all. I'm using a lua script to read the canbus, b...
by Copper280z
Sun Apr 19, 2015 2:51 am
Forum: RaceCapture App Operation and General Q&A
Topic: Accelerometer calibration
Replies: 14
Views: 6978

Accelerometer calibration

I'm mounting the RCP vertically, so that the label faces drivers left, green connector rear. Trying to calibrate the accelerometer for this I have switched the X and Z axes. If I click the Calibrate button, it sets AccelX to have a resting value of 1.0G, Z to have a resting value of 0G. If I tilt th...