Search found 10 matches

by z28pwr
Sat May 20, 2017 9:20 pm
Forum: OBDII PIDs discussion
Topic: OBD2: PID read fail:
Replies: 15
Views: 13597

Re-reading your response and yes, it happens when I hit run to restart the script but I only get the error when I change the pulse to any value below 1. If the value is 1 or greater it works fine as you can see prior to the error as once three error is thrown the script stops running. What error do ...
by z28pwr
Sat May 20, 2017 4:27 pm
Forum: OBDII PIDs discussion
Topic: OBD2: PID read fail:
Replies: 15
Views: 13597

Brent, I have the RPM lead connected but it was displaying half of the RPM value and when trying to set the pulse to half it would lose the channel and error out. This happened when trying to set it to anything below 1. What I ended up doing was multiplying it by 2 in my Lua Script to get the shiftx...
by z28pwr
Tue May 16, 2017 5:47 pm
Forum: OBDII PIDs discussion
Topic: OBD2: PID read fail:
Replies: 15
Views: 13597

Brent, I upgraded the firmware to 2.11.0 and increased the frequency to 50Hz and the RPM's stopped displaying in the dashboard but I couldn't mess with it as I had to get to grid. The car is very loud so I try not to turn it on in the neighborhood (non street legal). I've wired a shift light before ...
by z28pwr
Mon May 15, 2017 7:15 pm
Forum: OBDII PIDs discussion
Topic: OBD2: PID read fail:
Replies: 15
Views: 13597

Brent, if I want to hardcode the RPM do I need to purchase the CoilX or can I run the RPM pulse wire to RaceCapture if it's a 2006 Mazda Miata?
by z28pwr
Wed May 03, 2017 10:13 pm
Forum: OBDII PIDs discussion
Topic: OBD2: PID read fail:
Replies: 15
Views: 13597

Thanks, I'll give that a try during this weekends race and report back.
by z28pwr
Tue May 02, 2017 5:32 am
Forum: OBDII PIDs discussion
Topic: OBD2: PID read fail:
Replies: 15
Views: 13597

Brent, I continue to be plagued by this issue where it only reads the RPM every so often and the biggest problem is that as the car is moving up in the RPM's it only reads it every 400 RPM's or so which is an issue. I didn't have this problem when using EcuTek for logging on my other Miata. Below is...
by z28pwr
Sat Jan 21, 2017 9:10 pm
Forum: Lua Scripting
Topic: Only Works on first run
Replies: 5
Views: 10480

A PID read error means RCP did not receive a response from the ECU. Worth noting, the ECU can only service one PID request at a time. Do you have OBDII channels also enabled in the top level configuration? If you don't have the top level OBDII configuration enabled, could you enable that for say, R...
by z28pwr
Fri Jan 20, 2017 3:20 am
Forum: OBDII PIDs discussion
Topic: OBD2: PID read fail:
Replies: 15
Views: 13597

OBD2: PID read fail:

I'm seeing numerous OBD2: PID read fail: errors when polling the log (1 every 3 seconds) and it seems to get worse the more PID's I try to query. I increased the tick rate to 25 and it helped a little. Is this a bug or is there a wiring issue somewhere? I'm running RC Pro MK2 2.10.2?
by z28pwr
Fri Jan 20, 2017 3:14 am
Forum: Lua Scripting
Topic: Only Works on first run
Replies: 5
Views: 10480

Thanks Brent, you are correct the issue is that at times it's failing to obtain a reading for that PID and returning the nil value. I modified the script to account for a nil value but why am I seeing so many OBD2: PID read fail errors? I seem to get one every 3 seconds or so and it does'n t matter ...
by z28pwr
Wed Jan 18, 2017 4:57 am
Forum: Lua Scripting
Topic: Only Works on first run
Replies: 5
Views: 10480

Only Works on first run

I'm just getting started with Race Capture and want to output the data to the console to later build other scripts and when the script runs the first time it shows the correct value which is 0 for RPM and 127 for engine temperature but then it states that it can't read the values for several iterati...