Search found 5 matches

by Elevenssc
Sat Apr 29, 2017 7:18 pm
Forum: Installation
Topic: Megajolt E - Debug no spark at initial start
Replies: 9
Views: 6568

Finally got some garage time :-) Ive got good spark at the coils. Spark at the plug is weak to non existent. I'd planned to replace the donor wires once I got the car started, but it looks like I need to do it sooner. Does anyone know if I can get the clip-on style coil connector in a "make your own...
by Elevenssc
Fri Apr 28, 2017 2:15 am
Forum: Installation
Topic: Megajolt E - Debug no spark at initial start
Replies: 9
Views: 6568

Yes...Got spark, but still no start. Debugging coil integrity now.

Oh the joy of bone yard roulette :-)
by Elevenssc
Mon Apr 24, 2017 11:54 am
Forum: Installation
Topic: Megajolt E - Debug no spark at initial start
Replies: 9
Views: 6568

Here's a pic...
by Elevenssc
Sat Apr 22, 2017 7:46 pm
Forum: Installation
Topic: Megajolt E - Debug no spark at initial start
Replies: 9
Views: 6568

Update... Pulled another mag pick-up, EDIS-8, and coil from donor cars. Replaced the mag pickup with no success. Next step was to verify voltage and continuity at the EDIS. In the process, I noticed that the wiring diagram on the website may be wrong (which I find hard to believe, but possible). Pin...
by Elevenssc
Sun Apr 09, 2017 1:56 am
Forum: Installation
Topic: Megajolt E - Debug no spark at initial start
Replies: 9
Views: 6568

Megajolt E - Debug no spark at initial start

I hope this is the right forum for this question. I'm new to the Megajolt world so bear with me as I get up to speed. I want to thank you all in advance for your help with getting me back on the road. Some background info... 1970 340 ran fine with distributor and MSD6AL EDIS-8 is new-old stock Coils...