Search found 70 matches

by JMcDonough
Sun Jun 14, 2015 10:25 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14017

Gotcha. So you're saying - if you disable your Lua scripting, you don't see the empty initial files upon triggering? The distance behavior changed when we re-worked the lap timing algorithm in a recent release. Also looking at restoring the default behavior in 2.8.3 as well. To close the loop on th...
by JMcDonough
Wed Jun 10, 2015 10:16 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14017

Thanks Josh for the update. On the distance topic, are you triggering start/finish points via lapping on a circuit or point-point track, or just driving around for a bit? On the 2nd point, did you remove the Lua scripting and then triggered a log file manually? We're looking to address this in the ...
by JMcDonough
Wed Jun 10, 2015 10:05 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14017

I updated to 2.8.2 and tried again. Still get 1 file with nothing, then the following file with data and the first dozen or so lines out of time order. After that, it's all good. Still no distance values at all. GPS set to 10Hz. I removed all of the lua scripting (logging a bunch of CAN data) and th...
by JMcDonough
Sat May 30, 2015 2:09 pm
Forum: RaceCapture/Pro General Q&A
Topic: Data Analysis Software - Motec, Gems, AEM
Replies: 119
Views: 123421

Hi mavab91, I want to say I've seen that error before as well. 2 suggestions to try: 1. If that file is open in another program (Excel), close that program and try the import again. 2. Try opening the .csv file in Excel, then re-saving (maybe with a new name) as a csv and closing. Hope this helps.
by JMcDonough
Fri May 29, 2015 2:07 pm
Forum: RaceCapture/Pro General Q&A
Topic: Data Analysis Software - Motec, Gems, AEM
Replies: 119
Views: 123421

My experience echo's bmotorsports's. I have been post processing (in excel) the distance data from the GPS speed. At 50Hz, the raw distance data coming out of RCP was not accurate. I switched to 10Hz, which has been giving better position data, and creating my own distance data channel based on spee...
by JMcDonough
Wed May 27, 2015 8:17 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14017

In my case, I was powered on the entire time the logs were collected (RCP powered through the OBD connection). It stays powered on whenever connected to the OBD port, even if the car is off. I've been using the same micro SD card from the beginning. 32gb class 10 SanDisk ultra card. I didn't see the...
by JMcDonough
Sat May 23, 2015 9:38 pm
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14017

Running 2.8.1 firm and the 1.3.1 app. I now also get files with zero data, but the subsequent file has the correct data, so no runs were actually missed. All runs were started with a manual RCP button press. I did notice a quick flash of the red LED on the RCP right after the button is pressed. To h...
by JMcDonough
Fri May 15, 2015 3:44 pm
Forum: RaceCapture App Operation and General Q&A
Topic: separate start/finish line setup
Replies: 3
Views: 3084

I've been manually starting and stopping for my auto-x runs, but did you see this part of the documentation?:

http://www.autosportlabs.net/RaceCaptur ... nish_Lines
by JMcDonough
Tue May 05, 2015 3:52 am
Forum: RaceCapture/Pro General Q&A
Topic: Missing data, no explanation why
Replies: 31
Views: 14017

Had a somewhat similar experience during an autocross run: Did 2 runs back to back. Started RCP before the first run. Stopped it after the 2nd run. 1 log file resulted (as expected), but only included the final half of the 2nd run. It also jumped from RC_31.LOG (preceding file) to RC_43.LOG when tha...
by JMcDonough
Thu Apr 30, 2015 12:47 pm
Forum: Bug Reporting
Topic: Distance Channel Calculation Error
Replies: 3
Views: 3747

Thanks, Brent & co. If I look closely at the GPS data, it is pretty noisy and occasionally will jump around mid run. That would explain the erroneous distance values. I've been running at 50Hz. Per the GPS How-To, http://www.autosportlabs.net/RaceCapturePro2_GPS , I'll drop it down to 10Hz and see i...
by JMcDonough
Thu Apr 16, 2015 1:15 am
Forum: Bug Reporting
Topic: Distance Channel Calculation Error
Replies: 3
Views: 3747

Distance Channel Calculation Error

Comparing some of my RCP data with a friend's DL1 at the same autocross revealed very different distances between the two systems. The RCP was distance appears about 1.4x the DL1's data (this is after converting the RCP's miles to match the DL1's km convention). If I take the speed channel (in mph) ...
by JMcDonough
Tue Apr 14, 2015 7:15 pm
Forum: Lua Scripting
Topic: Trying to Write Script to Parse CAN by Bit - Help Needed
Replies: 3
Views: 2477

I watch the log as the script starts to run and all I saw was indication that the lua script crashed. No indication of what line or anything. Is that typical?

Red light comes on. Does that mean it has reset?

I can post the log file output if that would be helpful.
by JMcDonough
Tue Apr 14, 2015 7:08 pm
Forum: RaceCapture/Pro General Q&A
Topic: Data Analysis Software - Motec, Gems, AEM
Replies: 119
Views: 123421

The UTC column is derived from GPS, correct. Could you try a log from a drive around the block, with valid GPS data? I did some logs where the GPS had signal. Script ran flawlessly. For the purposes of garage/indoor testing (no GPS data or GPS wire disconnected) it would still be nice to have the s...
by JMcDonough
Sat Apr 11, 2015 2:30 am
Forum: Lua Scripting
Topic: Trying to Write Script to Parse CAN by Bit - Help Needed
Replies: 3
Views: 2477

Trying to Write Script to Parse CAN by Bit - Help Needed

Background: The vehicle I'm trying to log CAN data on has signals that do not fall evenly on the bytes like the script at the bottom of this page provides: http://www.autosportlabs.net/CAN_Bus_Integration So, I'm trying to write my own. I've been using http://www.lua.org/cgi-bin/demo to test lua cod...
by JMcDonough
Sat Apr 11, 2015 12:35 am
Forum: RaceCapture/Pro General Q&A
Topic: Data Analysis Software - Motec, Gems, AEM
Replies: 119
Views: 123421

Having troubles with the latest version of the script (1.7). Any help would be appreciated. First off, I'm using data collected from the car while sitting in the garage, so all 0's for the GPS data channels. When I run with GPS cleanup enabled I get stuck in the while loop that outputs the following...