Search found 49 matches

by psfp
Thu Sep 28, 2017 5:47 pm
Forum: RaceCapture App Operation and General Q&A
Topic: Raspberry Pi support - enables a hard-wired, dedicated dash
Replies: 119
Views: 61832

Ok, I will be able to do more tests on the weekend. So far, it is stable when running the app not connected to RCP after I included the "cursor = 1" line in Kivy's config.ini file. I noticed it freezes if I click the mouse buttons several times in a short interval, but it doesn't bother me at this t...
by psfp
Thu Sep 28, 2017 5:29 pm
Forum: RaceCapture App Bug Reporting / Feature Requests
Topic: Android / Raspberry request - shortcut to Exit the app
Replies: 2
Views: 1394

Android / Raspberry request - shortcut to Exit the app

Hi Brent, Would you consider to add a shortcut to exit the app, like a double "back" button click, and/or double "escape" key when using keyboard? It would help me in the Raspberry install, so I could exit the app to change settings when the app is starting automatically and mouse cursor is turned o...
by psfp
Thu Sep 28, 2017 5:25 pm
Forum: RaceCapture App Bug Reporting / Feature Requests
Topic: Android APP - "app has stopped" message when Exit
Replies: 11
Views: 4111

Android APP - "app has stopped" message when Exit

Hi Brent, Not sure if it was reported before, but I'm receiving a "Unfortunately, Race Capture has stopped." message when the app is finished by clicking the Exit option in menu. It happens every time in my Galaxy Note 4 and Galaxy S3. Also, if I switch to another app and return to Race Capture, I g...
by psfp
Wed Sep 27, 2017 11:20 pm
Forum: RaceCapture App Operation and General Q&A
Topic: Raspberry Pi support - enables a hard-wired, dedicated dash
Replies: 119
Views: 61832

Brent, is there any way to show mouse cursor in the App? Perhaps some initialization config. I'm doing some tests with Raspbian full and VNC, but the App in only shown in the HDMI screen, not in VNC viewer. However, the mouse is working in the APP, but I have to guess his position. Edit: I managed t...
by psfp
Wed Sep 27, 2017 1:20 am
Forum: RaceCapture App Operation and General Q&A
Topic: Raspberry Pi support - enables a hard-wired, dedicated dash
Replies: 119
Views: 61832

Alright, so I have to figure out how to do the initial setup, including gauge settings, etc.
by psfp
Wed Sep 27, 2017 12:54 am
Forum: RaceCapture App Operation and General Q&A
Topic: Raspberry Pi support - enables a hard-wired, dedicated dash
Replies: 119
Views: 61832

Hi Brent,
Well, I didn't realize that. The idea was to use my current headunit to display the Racecapture info through the HDMI port. I can do that with my cellphone output, but there is some lag from wireless connection. Does it mean there is no way to navigate using the keyboard only?
by psfp
Wed Sep 27, 2017 12:29 am
Forum: RaceCapture App Operation and General Q&A
Topic: Raspberry Pi support - enables a hard-wired, dedicated dash
Replies: 119
Views: 61832

Guys, I have zero knowledge on linux/raspberry pi stuff. I managed to install Racecapture on a fresh Rasbian Stretch Lite image, using wifi, but I can't use a mouse to control the app. I'm not using a touchscreen, but regular keyboard and mouse. Can anyone help me?
by psfp
Tue Sep 26, 2017 2:17 pm
Forum: Hardware and Installation
Topic: Ground question
Replies: 2
Views: 2915

Where do you get the 12v power from?

If you are using the OBDII cable, you shouldn't need an additional ground wire. If you are NOT using the OBDII cable, you must add a ground wire to your setup.
by psfp
Tue Sep 26, 2017 2:14 pm
Forum: Lua Scripting
Topic: Im going insane. Help required geeting 2 scripts to work
Replies: 5
Views: 3581

Is your fuel average function working? Where did you set the maxAvg value? And where did you initialize the fuel2Index variable?

Your idea is to smooth the fuel reading, is it right? You can try this setting as well:

viewtopic.php?p=25368&highlight=alpha#25368
by psfp
Wed Sep 20, 2017 11:57 pm
Forum: RaceCapture App Bug Reporting / Feature Requests
Topic: Windows 1.11.0 App crashing
Replies: 8
Views: 4882

Hi Brent,

I had the same results as GTech.

It happens on Analog Sensors and Analysis menus. All other seem to work as expected. App version 1.10.2 has the same problem, while 1.9.0 runs just fine.
by psfp
Wed Sep 20, 2017 10:54 pm
Forum: ShiftX2
Topic: Linear graph script/behavior
Replies: 4
Views: 3663

Hi Brent, I got it "fixed". Now the shift light represents the 4000 to 7000 range. The first LED turns on at 4000 rpm. Anything below 4000 rpm is ignored by the script. Basically, the ShiftX2 is configured to work from 0 to 3000 rpm and my script converts the RPM value by subtracting 4000 from the r...
by psfp
Tue Sep 12, 2017 10:32 pm
Forum: ShiftX2
Topic: Crashing?
Replies: 5
Views: 3999

Regarding the shift light behavior, would you mind to try the settings below? function sxOnUpdate() --add your code to update ShiftX2 alerts or linear graph during run time. --Runs continuously based on tickRate. --uncomment the below for Direct RPM on input 0 local vRPM = getTimerRpm(0&...
by psfp
Tue Sep 12, 2017 7:08 pm
Forum: ShiftX2
Topic: Crashing?
Replies: 5
Views: 3999

Try to delete all unused ShiftX2 functions and add collectgarbage() to your onTick function. It should help with memory issues.
by psfp
Mon Sep 11, 2017 4:04 pm
Forum: ShiftX2
Topic: Linear graph script/behavior
Replies: 4
Views: 3663

Linear graph script/behavior

Hi guys, I'm using a 1000 to 2000 rpm range to test my ShiftX2 in my garage, but when I reach the first threshold, the first 4 leds light up at the same time. I was expecting a smooth transition from the very first led. See a video in the link below: https://youtu.be/w1ct4EyeX4s Here is my script: s...
by psfp
Mon Sep 11, 2017 4:28 am
Forum: Hardware and Installation
Topic: GPIO - 5V reference
Replies: 3
Views: 3228

Thanks Brent. It worked. Unfortunately, looks like RaceCapture Pro isn't communicating to my car anymore. Not sure what may have caused it. I'll start a thread about it.

Edit: problem fixed, it was a bad connector. Everything is fine now.