Megajolt/E Mk2

General discussion on Autosport Labs, the mission, website, content, etc.

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
617sqn
Posts: 11
Joined: Tue Sep 14, 2010 7:52 pm
Location: England

Megajolt/E Mk2

Post by 617sqn »

Hi Guys.

I've recently bought a new Megajolt Mk2 here in England (Trigger-wheels.com), and actually fitted it into the car this morning, having transferred the map from my old v4. I'm at a loss as to why the ASL pages don't seem to picture the new unit, just the previous incarnation, and there are no updated instructions/manual for it. As an example, it features 3 green LED's but there's no indication as to what they are for, nor obviously how to "read" them. It would be nice, from my point of view, to have a comprehensive page (even if its short and to be read in conjunction with available on-line info) giving basic advice as to the function of these lights. The on-line pages need a re-read and comprehensive update, I reckon.

The USB connection is a bonus, and takes care of previous problems with serial adapters, RJ11 cable problems etc. I bought a new cable with the Mk2 and will keep it for the units sole use.

Any help, anyone ?

Andy G.

England

PS Brent. Installation images will be sent via email as soon as I've a chance to capture them. :-)

simontr6
Posts: 9
Joined: Wed Oct 22, 2014 8:18 pm
Location: West Horsley, Surrey, UK.

Re: Megajolt/E Mk2

Post by simontr6 »

I just bought a new Megajolt MK2. The previous Megajolt stopped advancing my EDIS 6 unit. The bottom green light is power on. The middle Green light is indicating that the Megajolt is receiving incoming RPMs from the EDIS . The top green light is indicating that the megajolt is advancing the EDIS .

simontr6
Posts: 9
Joined: Wed Oct 22, 2014 8:18 pm
Location: West Horsley, Surrey, UK.

Re: Megajolt/E Mk2

Post by simontr6 »

I cannot seem to post pictures on your post. If you go to my post, you will see the lights working on the Megajolt MK2.
viewtopic.php?t=6284

617sqn
Posts: 11
Joined: Tue Sep 14, 2010 7:52 pm
Location: England

Re: Megajolt/E Mk2

Post by 617sqn »

Excellent info, thanks. It should really ship with the unit though, shouldn't it ?

Thanks, Andy G

simontr6
Posts: 9
Joined: Wed Oct 22, 2014 8:18 pm
Location: West Horsley, Surrey, UK.

Re: Megajolt/E Mk2

Post by simontr6 »


617sqn
Posts: 11
Joined: Tue Sep 14, 2010 7:52 pm
Location: England

Re: Megajolt/E Mk2

Post by 617sqn »

Hi All.

I've recently had to purchase a new Megajolt, as the old one's USB port parted company with the board !! It looks as though the amount of solder applied in the factory was rather inadequate. I'm not in the least bit heavy handed and I'd say in truth that I've only ever connected it to my lap top three times since I've owned it. It's now binned. I intend strengthening the location of this component on the board to prevent a re-occurrence.

As I can no longer read the map that was installed, I've basically got to start again, and as I have a few maps saved it's trial and error. Among those I've collected are 2 that are TPS maps used on the same type of engine. Is there some sensible way of "converting" those to be relevant to a MAP configured Megajolt ?

Any help appreciated.

Andy G. England.

brentp
Site Admin
Posts: 6172
Joined: Wed Jan 24, 2007 6:36 am

Re: Megajolt/E Mk2

Post by brentp »

Sorry to hear you broke the USB connector; If you still have it, it can be fixed by a electronics technician with experience in SMT rework. Should be fixable, and then you can pull the maps off of it.

For TPS -> map interpretation, you'll want to think of 100% TPS = 100 KPa MAP (Which is equivalent to wide open throttle). It's not exactly linear, but knowing that could get your started.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply