Migrating website to new hosting service!

Autosport Labs news and product announcement discussion.

Moderators: JeffC, rdoherty, stieg, brentp

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Migrating website to new hosting service!

Post by brentp »

We have an interesting relationship with our current hosting provider. While the support service is great- I mean, they are super responsive to trouble tickets- I still wish I wouldn't have to interact with them as much. :?

We are currently working on migrating Autosport Labs over to a more stable, powerful hosting service. After this is done I anticipate the periodic website "server errors' will be a quickly fading memory.

This migration work will continue over the next week. If possible, I'll provide links to the new sites for testing purposes. When all seems well, we will cross our fingers and make a crisp cut-over to the new system.

In the meantime, carry on...!
Last edited by brentp on Tue Jun 22, 2010 5:43 pm, edited 1 time in total.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Note - we have been testing the website migration and it looks pretty solid. The way the hosting is configured prevents simultaneous access to all of the websites. Best thing to do is throw the switch and fix any glitches that come up. I'm fairly confident the problems will be minor.

When the change goes into effect, DNS will be updating throughout the internet- so it may take a bit of time for you to get to the new site. To prevent confusion and duplicate data, the old servers will be disabled.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

NITROPIXIE
Posts: 704
Joined: Sun Sep 07, 2008 1:54 pm
Location: Fareham, GB

Post by NITROPIXIE »

All sounds great Brent. When will this likely happen???

To be honest fro my point of view there isn't anything wrong with the site as it is
1310 A-series Mini, lightened and built myself. V4 board and loving it

Rasputin22 - The Mini Forum
Rasputin22 - MK1 Golf Forum

Megajolt repair for the UK available

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

About 6 hours and counting. the primary disruption will be waiting for the DNS servers to update.

I'm surprised the problems haven't been noticable to you- "Internal Server Error" and "cannot connect to database" are the common errors I've seen. it's a classic problem of overselling user accounts. If it's annoying for me I pretty confident it's been prominent enough to cause problems for others! One manifestation of the problem is when a double post appears in the forums: it's likely because the system only partially handled the request, then generated an error. The user then re-tries, usually resulting in the double-post.

So we're making all of our 3 sites more stable, and also building up capacity, which we will need in the future.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Actually, we're delaying by about 24-36 hours- we've updated the DNS settings to refresh more frequently. We'll let the internet flush itself with the current DNS TTL (Time To Live)- once most everyone is running with the updated, shortened TTL we'll make the switchover.

It's a technical way for saying we're trying to reduce the perceived down-time for you guys. :)
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

We made the switch! Please reply to this thread if you see this message.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

I can see the DNS entries updating from different vantage points on the 'net. Good.

The server seems pretty snappy too.. :P :D

Ratsun
Posts: 8
Joined: Sat Jun 06, 2009 2:33 am
Location: NW Arkansas

Post by Ratsun »

All seems well!

Yeah, I had gotten the errors you mentioned a couple of times, but just tried again and it was fine.
Hickory Hill Racing Team
We started with nothing and still have most of it left!

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Thanks! Server response time has visibly improved- every page load seems to be very snappy.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Ken555
Posts: 92
Joined: Fri Sep 07, 2007 8:24 pm
Location: Aberdeenshire
Contact:

Post by Ken555 »

brentp wrote:We made the switch! Please reply to this thread if you see this message.
found you

NITROPIXIE
Posts: 704
Joined: Sun Sep 07, 2008 1:54 pm
Location: Fareham, GB

Post by NITROPIXIE »

Fantiddilyastic, the site is super smooth and very much quicker. Will make navigating the site a whole much better and easier for people to research previous threads.

Well done :D
1310 A-series Mini, lightened and built myself. V4 board and loving it

Rasputin22 - The Mini Forum
Rasputin22 - MK1 Golf Forum

Megajolt repair for the UK available

Gassed'58
Posts: 21
Joined: Sat Sep 13, 2008 10:22 pm
Location: ..... Wales ....

Post by Gassed'58 »

.............................All cool here, well done all concerned...................

dannyb
Posts: 18
Joined: Sun Jul 12, 2009 10:19 pm
Location: Leeds, UK

Post by dannyb »

All good this end :D
DannyB

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Thanks! Performance and stability continues to look really good.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

DannyP
Posts: 417
Joined: Sun Apr 09, 2006 3:48 pm

Post by DannyP »

Looking fast on page loads, no more errors.

Post Reply