Page 1 of 1

Limiter running! One bug...

Posted: Sun Nov 18, 2007 2:22 am
by sunray
Thanks to Brent for allowing me to test this little unit. I figured I'd share my install with everyone. I decided to installed the beta board inside the mjlj case. My case is attached to a very old version of a restraints control module. Hard to believe Toyota had a unit like that back in 1974. Is only purpose now is to hold the mjlj.



I drilled a hole next to the serial port to allow the rev limiter harness to be fed outside the case.


My plan was to wire the rev limiter on its own with separate circuit protection just in case the unit demanded any current that my other circuit wasn't set-up for.


I ran some double walled shrink tube to protect the harness from abrasion on the mjlj case.


Sourced a pico connector to make the act of removing components easier for any later troubleshooting.


Now I added an ato fuse holder and started the unit up. It ran exactly as normal. I loaded one of my maps but set the rev limit to a dismal 2500rpm just to see if it worked. IT DID! Then I tried 3000rpm, YAY! Now I set it higher and got some nice race car stlye backfires too. I bet at my normal limit I will get some flames due to the carbs just feeding fuel through.


The only bug that I should report is when I first loaded the map set to 2500rpm, I uploaded the config to the mjlj. I started the car and gave it a couple runs to the limit. It worked fine. The car was cold so it stalled. When I restarted the engine, the limit did not kick in at 2500rpm. So I plugged the laptop in and to my surprise the original map had somehow loaded and was set back to 8000rpm.

Maybe just a user error on my part??

Posted: Sun Nov 18, 2007 5:10 am
by brentp
Excellent! thanks for the initial test results!

It's wise that you tested at low RPMs. :) For saving the settings, you might've forgotten to hit 'flash' to store your configuration in the processors non-volatile memory?

Would like to get your opinion on how harsh the rev limiting is when you do probe activating it under load. Remember, 100 RPMs before the hard limit the advance goes to zero, so it should be smoother than simply slamming the door shut.

if it is still harsh then we can try a firmware update that alternates activating the rev limiter output every other ignition event.

Since we're rev limiting via ignition and not fuel, sustained rev limiting should yield some neat flames, be sure to watch for that. Yikes!

If it makes sense for your installation, you may consider desoldering the screw terminals and attaching the wires straight to the pads. Another thing you may consider is internally wire the ground and trigger connections, and just bring the two wires that power the coil to the outside of the case.

Thanks again,

Posted: Sun Nov 18, 2007 1:04 pm
by DannyP
I was planning on internal wiring for all of it, and using two of the unused molex pins to get the switched output to the coil.

Posted: Sun Nov 18, 2007 6:59 pm
by sunray
I think that was it Brent. I forgot to commit the configuration to flash so it just got dumped.

Posted: Mon Nov 19, 2007 5:23 pm
by Ken555
Will these fit the version 2 boards ?
And if so any update on sales of them starting ?

Posted: Tue Nov 27, 2007 6:44 pm
by brentp
They will absolutely work with V2 boards. In fact, we could use a V2 tester, I'll PM you.

We are still out several weeks before we can decide to make these available. Thanks for your patience!

Posted: Sun Dec 09, 2007 5:44 pm
by sunray
Okay so the snow stopped testing for a bit but it was dry last night but they are calling for snow today. I went out, shot some crappy videos and found another *possible* bug. Truthfully it may have been happening before and I may not have noticed.

I noticed my tach and the laptop running the tuning software didn't agree on the rpm, it was usually around 500rpm different. I figured my dated tach was just wrong. Then I was loading different configs and noticed someting odd. With key on engine off (KOEO) the software read 437rpm. Now with the KOEO the engine obviously is not spinning at all. And according to my car's tach the rev limit is kicking in around 500rpm late. BAD NEWS! What do you think Brent?

Otherwise, the limiter stops the engine dead under load. The tach of course goes completely dead while the current ramps down.

Oh and here's some video. No flames, too bad. :(

Posted: Mon Dec 10, 2007 4:25 pm
by brentp
Hi Chris,

Great testing. From your videos it really seems to cut power!

The 457 RPM showing up when the engine stops running is a long-known artifact of the MJLJ firmware- it's showing the "lowest measurable" RPM i.e. the MJLJ can only calculate RPM down to 457 RPMs. It may seem like it's related to your tach offset, but it's not.

If you haven't already, you might want to do a datalogging session and possibly have a human in the other seat watch the runtime gauges to see when soft rev limiting kicks in and then the hard rev limiting. You might want to approach rev limiting under light load so the laptop doesn't fly out of your handds. :D

If you do have a chance to do a datalog while activating the rev limit, please attach it to the thread.

Thanks again!


Posted: Wed Jan 09, 2008 7:05 pm
by -Ad-
Good to see the beta test limiter working well.
Sounds cool in the "fly-by" vid too 8) :lol:
Lamborghini murci?lago history