RaceCapture Pro MK2 no wifi, bluetooth not working

General Q&A specific to RaceCapture/Pro. For app related questions post in the RaceCapture App forum. also see the <a href="http://www.autosportlabs.net/RaceCapture">RaceCapture Information Page</a>

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
brendanmead
Posts: 7
Joined: Sat Sep 25, 2021 4:58 pm

RaceCapture Pro MK2 no wifi, bluetooth not working

Post by brendanmead »

I have a RaceCapture Pro MK2 which I am trying to configure. I am not able to detect a wifi signal from the device. Wifi is enabled in settings but does not initialize.
I am also not able to connect to Bluetooth. I am able to see "RaceCapture Pro", but the password "1234" does not work. I have tried changing the bluetooth name and password but am still not able to connect. I have tried a number of different configurations and many reboots. I will paste the start up log below.

[Kivy ] v1.11.1
[Logger ] Record log in C:\Users\i\.kivy\logs\kivy_21-09-29_21.txt
[Kivy ] Installed at "C:\PROGRA~2\RACECA~1.2\kivy\__init__.pyc"
[Python ] v2.7.11 (v2.7.11:6d1b6a68f775, Dec 5 2015, 20:32:19) [MSC v.1500 32 bit (Intel)]
[Python ] Interpreter at "C:\Program Files (x86)\RaceCapture_v1.16.2\racecapture.exe"
[Deprecated ] Python 2 Kivy support has been deprecated. The Kivy release after 1.11.0 will not support Python 2 anymore
[Factory ] 184 symbols loaded
[Image ] Providers: img_tex, img_dds, img_sdl2, img_gif (img_pil, img_ffpyplayer ignored)
[Window ] Provider: sdl2
[GL ] Using the "OpenGL" graphics system
[GL ] GLEW initialization succeeded
[GL ] Backend used <glew>
[GL ] OpenGL version <4.6.0 - Build 27.20.100.9126>
[GL ] OpenGL vendor <Intel>
[GL ] OpenGL renderer <Intel(R) UHD Graphics 630>
[GL ] OpenGL parsed version: 4, 6
[GL ] Shading version <4.60 - Build 27.20.100.9126>
[GL ] Texture max size <16384>
[GL ] Texture max units <32>
[Window ] auto add sdl2 input provider
[Window ] virtual keyboard not allowed, single mode, not docked
[Clipboard ] Provider: winctypes
[Text ] Provider: sdl2
[UserPrefs ] Data Dir is: C:\Users\i\AppData\Roaming\racecapture
[UserPrefs ] Validating preferences
[UserPrefs ] Current dir for preferences:export_file_dir does not exist; setting default path C:\Users\Documents
[UserPrefs ] Current dir for preferences:import_datalog_dir does not exist; setting default path C:\Users\Documents
[AppConfig ] using user storage directory: C:\Users\i\AppData\Roaming\racecapture
[TelemetryManager] on_telemetry_enabled: True
[TelemetryManager] start() telemetry_enabled: True cell_enabled: False
[TelemetryManager] self._should_connect is false, not connecting
[GL ] NPOT texture support is available
[Base ] Start application main loop
[RaceCaptureApp]Datastore Path:C:\Users\i\AppData\Roaming\racecapture\datastore.sq3
[RaceCaptureApp]initializing datastore...
[RaceCaptureApp] initializing rc comms with, conn type: Serial
[RCPAPI ] msg_rx_worker starting
[RCPAPI ] cmd_sequence_worker starting
[RCPAPI ] auto_detect_worker starting
[RCPAPI ] trying last known device before each other device: COM6
[RaceCaptureApp] Current presets loaded
[DataStore ] Applying db migrations: []
[DataStore ] db migrations complete
[RaceCaptureApp] Current tracks loaded
[RCPAPI ] trying last known device before each other device: COM6
[RCPAPI ] trying last known device before each other device: COM6
[DataBusPump ] Checking for streaming API support
[StatusPump ] status_worker starting
[TelemetryManager] on_data_connected: True
[TelemetryManager] start() telemetry_enabled: True cell_enabled: False
[TelemetryManager] self._should_connect is false, not connecting
[DataBusPump ] device supports streaming
[RcpConfig ] Config version 2.17.8 Loaded
[TelemetryManager] on_cell_enabled: True
[TelemetryManager] Got new device id
[TelemetryManager] start() telemetry_enabled: True cell_enabled: True
[TelemetryManager] self._should_connect is false, not connecting
[DataBusPump ] Sample Meta is stale, requesting meta
[SessionRecorder] ChannelMeta changed - stop recording
[TelemetryManager] Got channels
[TelemetryManager] start() telemetry_enabled: True cell_enabled: True
[TelemetryManager] self._should_connect is false, not connecting
[RaceCaptureApp] Config written
[TelemetryManager] Got channels
[TelemetryManager] start() telemetry_enabled: True cell_enabled: True
[TelemetryManager] self._should_connect is false, not connecting
[TelemetryManager] on_data_connected: False
[RCPAPI ] trying last known device before each other device: COM6
[RCPAPI ] trying last known device before each other device: COM6
[DataBusPump ] Checking for streaming API support
[StatusPump ] Already running
[TelemetryManager] on_data_connected: True
[TelemetryManager] start() telemetry_enabled: True cell_enabled: True
[TelemetryManager] self._should_connect is false, not connecting
[DataBusPump ] device supports streaming

brentp
Site Admin
Posts: 6059
Joined: Wed Jan 24, 2007 6:36 am

Re: RaceCapture Pro MK2 no wifi, bluetooth not working

Post by brentp »

Hi,

RaceCapture/Pro MK2 does not have built-in bluetooth or wifi - they are enabled via external modules, plugged into the RJ11 ports on the front. Do you have these accessories with the unit?

For reference - RaceCapture/Pro MK3 does have bluetooth and wifi, built-in.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

brendanmead
Posts: 7
Joined: Sat Sep 25, 2021 4:58 pm

Re: RaceCapture Pro MK2 no wifi, bluetooth not working

Post by brendanmead »

Thanks. I was beginning to suspect that there was no built in wifi. I do have the bluetooth module, however. I am able to see "RaceCapturePro" under the available BT connections on my android device, but the password "1234" is rejected. I have tried to change the BT name and password in the settings, but haven't been able to connect.

brentp
Site Admin
Posts: 6059
Joined: Wed Jan 24, 2007 6:36 am

Re: RaceCapture Pro MK2 no wifi, bluetooth not working

Post by brentp »

The trick when changing the name or PIN is that you need to power cycle the hardware after writing the changes. Upon the next power cycle, it triggers the renaming and new PIN. Try cycling BT off / on on the android device, too. Ensure you specify only a numeric PIN.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

brendanmead
Posts: 7
Joined: Sat Sep 25, 2021 4:58 pm

Re: RaceCapture Pro MK2 no wifi, bluetooth not working

Post by brendanmead »

Thanks. I am able to see the updated BT name after recycling. However, I am not able to stay connected via bluetooth on any Android device.

I have tried with the default BT setup and with a custom name and I get the same results either way. I can find the BT name in my list of available BT devices, but when I try to pair, it seems to connect but then immediately disconnects. Once it disconnects, the RaceCapture BT becomes "dead", meaning I can still see it in the list of available devices, but when I tap it, is does nothing. It seems like it will only try to connect once, after that, it doesn't do anything, no matter how many times I try.

When I factory reset or change the BT name, I am able to "pair" again, but only the first time, and after that the BT network dies.

[DataStore ] db migrations complete
[RaceCaptureApp] Current tracks loaded
[RCPAPI ] trying last known device before each other device: COM6
[DataBusPump ] Checking for streaming API support
[StatusPump ] status_worker starting
[TelemetryManager] on_data_connected: True
[TelemetryManager] start() telemetry_enabled: True cell_enabled: False
[TelemetryManager] self._should_connect is false, not connecting
[DataBusPump ] device supports streaming
[DataBusPump ] Sample Meta is stale, requesting meta
[SessionRecorder] ChannelMeta changed - stop recording
[TelemetryManager] Got channels
[TelemetryManager] start() telemetry_enabled: True cell_enabled: False
[TelemetryManager] Device id, channels missing or RCP cell enabled when attempting to start. Aborting.
[RcpConfig ] Config version 2.17.8 Loaded
[TelemetryManager] on_cell_enabled: True
[TelemetryManager] Got new device id
[TelemetryManager] start() telemetry_enabled: True cell_enabled: True
[TelemetryManager] self._should_connect is false, not connecting
[GL ] Unpack subimage support is available
[RcpConfig ] Config version 2.17.8 Loaded
[UserPrefs ] Saving preferences
[TelemetryManager] on_data_connected: False

brendanmead
Posts: 7
Joined: Sat Sep 25, 2021 4:58 pm

Re: RaceCapture Pro MK2 no wifi, bluetooth not working

Post by brendanmead »

Please disregard previous question- all I needed to do was open the RaceCapture App. Very simple.

brentp
Site Admin
Posts: 6059
Joined: Wed Jan 24, 2007 6:36 am

Re: RaceCapture Pro MK2 no wifi, bluetooth not working

Post by brentp »

Glad you got it working!
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply