Lost OBDII channels (Rpm and tps)

General Q&A specific to RaceCapture/Pro. For app related questions post in the RaceCapture App forum. also see the <a href="http://www.autosportlabs.net/RaceCapture">RaceCapture Information Page</a>

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
Mugenlude
Posts: 20
Joined: Mon Apr 24, 2017 9:13 pm

Lost OBDII channels (Rpm and tps)

Post by Mugenlude »

I've had my setup working without issue, yesterday it suddenly lost data from my two OBDII channels (rpm and tps).

I've power cycled the RCPro, unplugged and replugged in the OBDII Legacy plug, confirmed it is plugged into the OBDII port on the car. Using the cable for power, so its working in that manner.

Troubleshooting ideas? Thanks.

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Hi,

While it's trying to get data from OBDII, try getting the RaceCapture log here, it might have some useful information:
https://wiki.autosportlabs.com/RaceCapt ... apture_Log

What year/make/model are you testing this on?

Also, can you try to get data from a 1995-2007 (not 2008+) vehicle? IOW, does it work on other vehicles?

Finally, you can double check your setup to ensure your OBDII is configured correctly. Also make sure CAN bus is set to 500K baud and verify other settings according to the guide here:
https://wiki.autosportlabs.com/OBD2CAN

Will watch for your progress. Thanks!
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Mugenlude
Posts: 20
Joined: Mon Apr 24, 2017 9:13 pm

Post by Mugenlude »

I will work on getting the log this evening when I'm near the car.

2002 Chevrolet Corvette Z06, I don't have any other OBDII vehicles that I could test this on.

I'm setup that way with my OBDII configuration.

Mugenlude
Posts: 20
Joined: Mon Apr 24, 2017 9:13 pm

Post by Mugenlude »

The cold winter is finally over, so I was able to get to the car... Here are some screen shots of what you requested.

Thanks.
Attachments
20180428_175240.jpg
20180428_175240.jpg (136.51 KiB) Viewed 3779 times
20180428_175153.jpg
20180428_175153.jpg (133.46 KiB) Viewed 3779 times
20180428_175341.jpg
20180428_175341.jpg (143.02 KiB) Viewed 3779 times

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Hi,

Thanks for the update. It would be good if you could check on other vehicles, from any year between 1996-> current..

If you don't get any data anywhere, we can certainly take a look at your OBD Legacy adapter to see if it needs repair. Just ping us at [email protected] if we need to go to that step.

Thanks,
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply