Firmware Upgrade problem

Race Capture Pro hardware installation- power, wiring, physical installation, etc. See the dedicated forum for Sensor related topics

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
stingg
Posts: 9
Joined: Mon Oct 07, 2013 4:03 pm

Firmware Upgrade problem

Post by stingg »

I'm trying to upgrade the firmware using the bat file provided. Somehow when I plug in the USB with the button pressed (3 Green led ligthed up) the device is detected as USB Input Device, Instead of Autosport Bootloader. I do really want to avoid opening up the case and do a fresh update. Am I doing something wrong in the sequence? I've installed the bootloader driver and previously I've updated the firmware once with no issue.

jcordle
Posts: 5
Joined: Thu Mar 27, 2014 11:03 pm

Re: Firmware Upgrade problem

Post by jcordle »

stingg wrote:I'm trying to upgrade the firmware using the bat file provided. Somehow when I plug in the USB with the button pressed (3 Green led ligthed up) the device is detected as USB Input Device, Instead of Autosport Bootloader. I do really want to avoid opening up the case and do a fresh update. Am I doing something wrong in the sequence? I've installed the bootloader driver and previously I've updated the firmware once with no issue.
The latest versions of the firmware (1.2 and above) require newer USB drivers. Were you able to do that?

brentp
Site Admin
Posts: 5986
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

stingg,

Separate drivers are required for the bootloader mode. Fortunately, they are automatically installed during the firmware update process. Make sure you download the latest firmware (currently 1.2.8) and run the .bat file that guides you though the installation process. Also, see the included instructions for installing.

Let us know how it works!
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

momostallion
Posts: 58
Joined: Wed Feb 12, 2014 1:48 pm
Location: dallas, tx

Post by momostallion »

just a note, with windows 8, i was unable to update firmware (from 1.1x to 1.2x)

windows 8 recognized the device fine with 1.1x firmware using the non V2 drivers but during the update process, the firmware update utility never found the device. this occurred on both my windows 8.1 machines.

i tried my windows 7 machine to perform the update, it worked perfect on the first attempt.

my win 8 machines now work fine reading the device on the new firmware with the new new V2 driver installed.

brentp
Site Admin
Posts: 5986
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Thanks for the update. looks like we need to double check it on windows 8; might be related to the unsigned drivers restriction.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply