2004 gto install

Race Capture Pro hardware installation- power, wiring, physical installation, etc. See the dedicated forum for Sensor related topics

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
carlos88
Posts: 17
Joined: Sun May 28, 2017 3:40 am
Location: NY

2004 gto install

Post by carlos88 »

Hey guys so i have a 240sx with a 2004 gto ls1 engine swap. i had the obd2can connector but it kept connecting and disconnecting so i never had consistent luck with it and decided to wiring up my racecapture pro mk3 directly to the sensors. wanted to share my info with you all.

Oil pressure - ECM Connector C2 - Pin 58 (BN/WH)
---- Sample 25hz
----Used the 150 PSI sensor preset built into the software
ECT - ECM Connector C1 - Pin 74 (YE)
---- Sample 1hz
---- Used the extended range temp sensor preset built into the software
TPS - ECM Connector C2 - Pin 24 (BU)
---- Sample -25hz
---- First put it on raw wrote down what the voltage was with my foot off the pedal and then floor it and wrote what the voltage was there. Then switched over to Interpolated Maping and put the 1st 4 values as my voltage without touching the pedal and put scale to 1. the 5th value I put the voltage to what i got with it floored and the scale to 100.
RPM - ECM Connector C2 - Pin 10 (BN)
---- Pulse per rotation -2
---- Timer speed medium
---- Sample 25hz


I also purchased these on ebay which makes it so convenient incase i need to remove my harness if i ever decide to finally installed a full cage.
https://www.ebay.com/itm/5Kit-4Pin-Way- ... 2749.l2649

Image
Image
Image
Last edited by carlos88 on Sun Apr 07, 2019 3:50 am, edited 1 time in total.

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Hi, didn't see the separate post about TPS.

Can you set the voltage of that channel to "Raw" mapping and then see the raw voltage change? That should get you started towards mapping, and verify you're actually seeing a varying voltage go into the port.

Thanks,
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

carlos88
Posts: 17
Joined: Sun May 28, 2017 3:40 am
Location: NY

Post by carlos88 »

The separate post is for the RPM. that one you replied to. thank you very much.

carlos88
Posts: 17
Joined: Sun May 28, 2017 3:40 am
Location: NY

Post by carlos88 »

Its been updated with the working rpm now. Incase anybody else has a blue/green ls1 ecu, this will work

brentp
Site Admin
Posts: 5956
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Fantastic. Thank you for confirming it works!
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply