RCP Mk2 Cellular Startup Issues

Setup and configuration for Race Capture Pro real-time telemetry features

Moderators: JeffC, rdoherty, stieg

Post Reply
shields8
Posts: 9
Joined: Fri Sep 18, 2020 7:17 pm

RCP Mk2 Cellular Startup Issues

Post by shields8 »

Hey Everyone,

I have a RCP MK2 that we've had for years and worked well but this year, went to start it up with a new sim and we do not get any cellular/telemetry status light (not lit up). We were trying some things with a telus SIM - that's a no go but the setup we now have is:

Latest firmware off of podium (we were several versions out of date as we have never updated)
Device ID is verified at matching my "device" on podium
Rogers Sim card using Rogers preset APN information.
The system status sticks in Initializing - I *think* it may have got to "Initialized". System recognizes the SIM phone number. This all leads me to believe the SIM is recognized and the APN info is correct.

The signal strength stays as "unknown" and the network status as "searching". No status light (top right green light on the MK2)

A couple different back and forths with writing configs but the logs state common Telemetry errors (I think):

[TelemetryManager] on_data_connected: True
[TelemetryManager] start() telemetry_enabled: False cell_enabled: False
[TelemetryManager] self._should_connect is false, not connecting
[DataBusPump ] device supports streaming
[DataBusPump ] Sample Meta is stale, requesting meta
[SessionRecorder] ChannelMeta changed - stop recording
[RcpConfig ] Config version 2.17.8 Loaded
[TelemetryManager] on_cell_enabled: True
[TelemetryManager] Got new device id

Cycling cellular off/on theme still persists:
[TelemetryManager] on_data_connected: True
[TelemetryManager] start() telemetry_enabled: False cell_enabled: False
[TelemetryManager] self._should_connect is false, not connecting

Any ideas?

Wifi is off.
Bluetooth is off
Background streaming is on

shields8
Posts: 9
Joined: Fri Sep 18, 2020 7:17 pm

Re: RCP Mk2 Cellular Startup Issues

Post by shields8 »

Error scripting is as follows:

*** RaceCapture/Pro MK2 2.17.8 ***
[watchdog] Initializing...
sizeof LoggerConfig: 10296
[CAN device] Initializing CAN0 with baud rate 500000
[CAN device] CAN init success!
[CAN device] Initializing CAN1 with baud rate 500000
[CAN device] CAN init success!
IMU: init res=0
GPS: Initializing...
[OBD2] Init current values
timebase/logging/telemetry sample rate: 50/25/10
[lua] Initializing Lua state
[lua] memory usage: 17KB
[lua] Starting Lua Task
[main] Setup Task complete!
[lua] Loading script. Length: 22
[lua] Successfully loaded script.
[gsm] powering off cellular module
GPS: provisioning attempt
GPS: probing baud rate: 921600
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
GPS: probing baud rate: 115200
GPS: probing baud rate: 9600
[cell] Auto-baud configuration
GPS: Using baud rate: 9600
GPS: module detected at: 9600
GPS: Configuring baud rate to: 115200
GPS: Message was successfully received.
GPS: Configuring was successful.
GPS: detected current update rate: 1
GPS: Configuring update rate to 25: win
GPS: Configuring NMEA messages
GPS: Message was successfully received.
GPS: Successfully configured NMEA
GPS: configure message type: win
GPS: configure navigation data message interval: win
GPS: Configuring Gnss Navigation Mode: win
GPS: Disabling NMEA messages
GPS: Message was successfully received.
GPS: Successfully disabled NMEA messages
GPS: provisioned
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[lapstats] Could not find track in db, falling back to fixed config 0
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

the above module repeats 4 times followed by:

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0

shields8
Posts: 9
Joined: Fri Sep 18, 2020 7:17 pm

Re: RCP Mk2 Cellular Startup Issues

Post by shields8 »

Where it currently is has full bars of 3G service.

I am now using Chatr which is Rogers pay as you go service
APN is chatrweb.apn

shields8
Posts: 9
Joined: Fri Sep 18, 2020 7:17 pm

Re: RCP Mk2 Cellular Startup Issues

Post by shields8 »

Making progress:

Did the firmware update again, power cycled.
SIM is now recognized
Phone number shows up
Says marginal signal strength but when i put it in my phone it's full 3g bars...


New Info Script:
[USB] Stopping telem stream on USB
[USB] Starting telem stream on USB
[USB] Stopping telem stream on USB
[USB] Starting telem stream on USB
[lapstats] Could not find track in db, falling back to fixed config 0
[cell] Network registered
[gsm] Network Operator: chatr
[sim900] GPRS Attached: yes
[sim900] IP address: 25.161.1.193

[sim900] Failed to connect to telemetry.podium.live:8080
[cell] Network registration failed: Unknown reason. Message code 4
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[USB] Stopping telem stream on USB
[USB] Starting telem stream on USB
[USB] Stopping telem stream on USB
[USB] Starting telem stream on USB
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[gsm] Failed to alter echoing.
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[Conn task] Too many connection attempts
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[Conn task] Too many connection attempts
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[gsm] Failed to alter echoing.
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 8
[cell] Command failed. Response: 3
[cell] Command failed. Response: 3
[cell] Command failed. Response: 3
[cell] Command failed. Response: 3
[cell] Command failed. Response: 3

shields8
Posts: 9
Joined: Fri Sep 18, 2020 7:17 pm

Re: RCP Mk2 Cellular Startup Issues

Post by shields8 »

Making progress:

Did the firmware update again, power cycled.
SIM is now recognized
Phone number shows up
Says marginal signal strength but when i put it in my phone it's full 3g bars...


New Info Script:
[USB] Stopping telem stream on USB
[USB] Starting telem stream on USB
[USB] Stopping telem stream on USB
[USB] Starting telem stream on USB
[lapstats] Could not find track in db, falling back to fixed config 0
[cell] Network registered
[gsm] Network Operator: chatr
[sim900] GPRS Attached: yes
[sim900] IP address: 25.161.1.193

[sim900] Failed to connect to telemetry.podium.live:8080
[cell] Network registration failed: Unknown reason. Message code 4
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[USB] Stopping telem stream on USB
[USB] Starting telem stream on USB
[USB] Stopping telem stream on USB
[USB] Starting telem stream on USB
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[gsm] Failed to alter echoing.
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[Conn task] Too many connection attempts
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[Conn task] Too many connection attempts
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[gsm] Failed to alter echoing.
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 0
[Conn task] not connected. retrying
[gsm] powering off cellular module
[gsm] power off response: false
[cell] Power cycling modem
[cell] Resetting modem...
[cell] Auto-baud configuration
[cell] auto-baud successful
[cell] manufacturer is SIMCOM_Ltd

[cell] Loading driver for SIM900
[gsm] signal strength rssi: 8
[cell] Command failed. Response: 3
[cell] Command failed. Response: 3
[cell] Command failed. Response: 3
[cell] Command failed. Response: 3
[cell] Command failed. Response: 3

Post Reply