Page 1 of 1

can't update firmware

Posted: Thu Jun 16, 2016 5:16 pm
by jeffmcaffer
I just installed a new RCP2 and am looking to update the firmware from 2.9.0 to 2.9.2. Using the RC app 1.53 on a Windows 10 machine I keep getting a dialog that says the app cannot communicate with the RCP and that I should power down, hold the RCP button and plug in the USB. When I do that the RCP red light and lower green light come on and I am unable to connect at all. If i [power up with 12V then I can communicate but cannot update.

I'm at a race weekend and would love to get this setup so I can use the WiFi with my GoPros etc.


Posted: Thu Jun 16, 2016 9:00 pm
by gizmodo
Did you install the USB drivers?

Posted: Thu Jun 16, 2016 9:38 pm
by jeffmcaffer
no. they seemed to be labelled for Windows 7 and Vista. I'm on Windows 10. when I try to install it Windows complains that there is no digital signature.

Should I need it for Windows? Is there a signed one around? (I can disable signing enforcement but would rather not if in the end this is not needed)


Posted: Fri Jun 17, 2016 5:46 pm
by brentp
Hi Jeff,

The driver we provide is only for Windows 8 and prior - Windows 10 has a built in driver that can recognize RaceCapture/Pro's built in USB-to-serial support; so please don't attempt to install that driver. ... ds#Windows

Aside from attempting to update firmware, does the app otherwise communicate with RaceCapture/Pro? You can read/write configuration and see the dashboard update? Related, when you plug in RCP, how does it show up under windows device manager?

Posted: Sat Jun 18, 2016 3:39 am
by jeffmcaffer
Hey Brent. I can talk to the RCP from my Windows machine via USB. I did some scripting and that seems to have worked. The device is detected and reading/writing configurations does not fail. It is just the firmware update that is problematic.

Note as well, I do not seem to be able to connect via Bluetooth from my Windows machine either. Pairing appears to work but the App does not find the device. Perhaps unrelated but thought I would mention


Posted: Mon Jun 20, 2016 4:16 pm
by brentp
Hi Jeff,

If you plug the unit in to USB while holding the button, does it go into bootloader mode with the Red flashing LED? if so, do you see it show up as a COM port in device manager?

Once you've verified that mode, can you try updating firmware with app 1.5.3, and also try the previous version, 1.4.2?

Failing that, could you give it a shot on a different computer?

Thanks for your patience while we sort it out!

Posted: Tue Jun 28, 2016 4:34 am
by jeffmcaffer
Unfortunately nothing is working. I have tried the old app (1.4.2), different computers (windows 10 and windows 8.1), with and without 12v power, ... Nothing seems to work.

The Win 8.1 computer would not even connect under any circumstances. The Win10 computers connect and seem to work fine for reading and writing configuration etc. But not the firmware up date. Both Win10 computers fail to connect in the special boot mode (usb power and holding the start button). The red light on the RCP comes on and flashes but no joy in the app.

We have the Sovern Historics this weekend at Pacific and it would be great to get this working so I can get WiFi and control my cameras etc. Any other thoughts on what to try?


Posted: Tue Jun 28, 2016 5:24 am
by brentp
Hi Jeff,

With Windows 8 you have to use the drivers we supply, but -- disable driver signing check. It's complicated but only seen on windows 8.

We outlined it here: ... requisites

Windows 10 is the one that has the built-in driver.

Regarding my previous question, when you're in bootloader mode in Win10, do you see RCP show up in device manager?

Posted: Tue Jun 28, 2016 5:50 am
by jeffmcaffer
Sorry, yes. Meant to say that the device shows up as Com3 both in and not in Bootloader mode on Windows 10 Windows makes the happy, USB device plugged in sound in both cases. In bootloader mode the app continually cycles through Searching Com3/Connecting. not sure if it is supposed to connect when the RCP is in bootloader...

Posted: Tue Jun 28, 2016 5:52 am
by brentp

The app won't connect while in bootloader mode; you'd normally go right to the firmware update screen to attempt the firmware upgrade.

Had you installed the drivers on Windows 8?

Posted: Tue Jun 28, 2016 6:06 am
by jeffmcaffer
did not install drivers on win8. it was never my machine so did not want to screw around with disabling signing etc. One was a corporate machine and that was locked down and the other was a loaner at the track... I could take the RCP to work and scroung some time on a Mac. Ultimately would be good to be able to do this on my own machines but that might solve the immediate problem... Didn't really think of that until just now. Kept assuming I needed 12v but at least for this I actually must run on USB power.

Posted: Wed Jun 29, 2016 5:46 am
by jeffmcaffer
OK. Got this working thanks to Brent;s patience. For the record, it was completely my fault. The App was working BUT I was not waiting long enough. The doc indicated that in some cases you would have to do the manual bootloader trick. Whenever I was seeing the update dialog telling me to do the bootloader startup I interpreted that as an error condition (i'd already done that startup and figured the app tried and failed so it was telling me to redo it). In the end I you just click the check mark and wait, it eventually notices and starts the update.

Suggest some more text to indicate that it is not an error and that you need to wait. Better yet, consolidate the instructions for saving the configuration and doing the bootloader startup into one dialog before the file selection. That way when you select the file and click OK, the update just starts.

In any event, thanks Brent.