Page 1 of 1

Linux dev install and connecting to RCP/mk2

Posted: Mon Sep 09, 2019 8:59 pm
by Copper280z
Due to a series of events, and a serious ass kicking at Solo Nationals, I'd like to get the datalogger updated and reinstalled in the racecar.

The only PC I have available is my ubuntu 18.04 laptop, and I'm not really much of a pro at it. I managed to get the source to execute, though I had to use a precompiled version of kivy 1.10 installed via conda, because I could not get pip to install it correctly.

Anyhow, the application runs but doesn't connect to the device. The bar at the top flashes between "connecting" and "Searching /dev/ttyACM0".

The os appears to be identifying it

Code: Select all

(base) [email protected]:~$ ls -l /dev/serial/by-id
total 0
lrwxrwxrwx 1 root root 13 Sep  9 16:23 usb-AutosportLabs_RaceCapture_Pro_Mk2_00000000011C-if00 -> ../../ttyACM0
The firmware on the device seems to be alive and well on firmware v2.8.4 and I can connect to it via bluetooth on my phone.

I tried doing the "alternate method" of flashing the firmware at first, but it fails with "Could not find bootloader".

Based on the trouble I had getting the dependencies sorted, I feel like it's likely an issue there, but that's getting a bit over my head. I've spent enough time on it now that I need to ask for help.

Posted: Mon Sep 09, 2019 10:55 pm
by Copper280z
Looks like it was a permissions issue, even though my user is in the dialout group.

Code: Select all

sudo chmod 666 /dev/ttyACM0
This fixed it for me and now I can talk to the RCP!

Edit, adding my user to the dialout group did work, I just forgot to log out and back in after.