Oil Pressure & Temp Reading Incorrect

Discussions on CAN mapping for ECUs, sensors, PDMs, and more.
Post Reply
mug23
Posts: 1
Joined: Sat Feb 15, 2020 6:41 am
Location: United States

Oil Pressure & Temp Reading Incorrect

Post by mug23 »

I'm running a Hondata Kpro v4 for a K24 engine and using RC3. I have successfully able to mapped the presets in the RC3 for Hondata Kpro using CAN bus. I'm able to see the correct readings on RaceCapture app on all the presets except the oil pressure and temp sensors. The oil pressure and temp readings on the RC app is so high and I'm pretty sure it has something to do with the formula not being correct? If anyone can help me how to correct the readings on the RC app to match the readings on my Kpro, that would be awesome.

Below are some screenshots of the readings of the oil pressure and temp.
Attachments
Incorrect oil temp and pressure reading. Need to know how to correct it so it can match the Kpro reading.
Incorrect oil temp and pressure reading. Need to know how to correct it so it can match the Kpro reading.
Dash1.JPG (80.86 KiB) Viewed 7114 times
Dash4.JPG
Dash4.JPG (94.19 KiB) Viewed 7114 times
This is the correct reading from the Kpro.
This is the correct reading from the Kpro.
Dash2.JPG (11.1 KiB) Viewed 7114 times

brentp
Site Admin
Posts: 6280
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

To scale it correctly, you would need to know the conversion formula for those sensors. That's something that Hondata would provide. if you can get that information, please share it here and we can help further. Thanks!
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply