Page 1 of 1

Legacy OBDII to CAN issues

Posted: Mon Jan 25, 2021 1:36 am
by DanielsDM
I'm having issues getting the Legacy OBDII to communicate with my Racecapture Pro MK2. My setup is using a Raspberry Pi to run the app. When I first got the Legacy OBDII unit I connected on the bench and everything worked fine. Now I'm further along on my project and connected in the car and have other sensor wired in. In doing so I have 12v+ connected to the MK2 terminal block. Reading through the documentation again I see that the adapter sends 12V+ from the OBDII port through the RJ45 connector. Perhaps the adapter is damaged now? If so, how do I test it to confirm? Can it be repaired?
The Mk2 seems to be working fine, reads the analog sensors correctly.

Re: Legacy OBDII to CAN issues

Posted: Mon Jan 25, 2021 7:21 pm
by brentp
Hi,

Thanks for posting. Some clarification questions. Are you saying at one point you were able to read OBDII data from the legacy adapter? But now, if you test it exactly the same way, you cannot?

Does the legacy adapter still supply power to RC if you have it plugged into the RJ45 connector, with every other power source disconnected? (terminal block / USB)

Re: Legacy OBDII to CAN issues

Posted: Tue Jan 26, 2021 4:41 am
by DanielsDM
Thanks for the response. To clarify I have tested the following setups:
1) Pre-CAN vehicle --> Legacy OBDII --> RCP MK2 --> Laptop running RC
USB connection to the laptop.
Legacy OBDII has RJ45 connector as supplied (no modifications)
**Was able to successfully configure the OBDII and read data.

2) RCP MK2 --> RaspberryPi/7"Pi Touchscreen connected by USB.
Powered the MK2 with a benchtop 12V powersupply connected to terminal block.
Powered RPi with a 12V to 5V/3A powersupply because the USB was enough for the touchscreen.
** I was able to successfully run RC on the RPi but only connected some analog sensors to the MK2 (no OBDII)

3) Pre-CAN vehicle --> Legacy OBDII --> RCP MK2 --> RaspberryPi/7"Pi Touchscreen
USB connection between MK2 and RPi
MK2 powered with vehicle 12V connected to terminal block.
RPi/Touchscreen powered by 5V powersupply (driven by vehicle 12V)
Legacy OBDII has RJ45 connector as supplied (no modifications)
**MK2 and RPi turn on, RC launches and 5V analog sensors read correctly, No data from OBDII

Re: Legacy OBDII to CAN issues

Posted: Tue Jan 26, 2021 4:48 pm
by brentp
The main gist of my question was:

Does 1) still work as originally tested?

Re: Legacy OBDII to CAN issues

Posted: Sat Jan 30, 2021 10:18 pm
by DanielsDM
Brent, I reconnected in setup 1) and I get nothing from OBDII. Went through the wiki instructions to make sure I'm not missing anything.
What's next to figure out the problem?

Re: Legacy OBDII to CAN issues

Posted: Sun Feb 14, 2021 8:21 pm
by DanielsDM
I did some more testing this weekend.
1) Swapped the cat5 cable between the Legacy OBDII and RCPMK2. This is running Racecapture on a PC. No change, still no data from OBDII.
2) Confirmed that the vehicle OBDII port is working by connecting to a scanner. Receives data.
3) Connected to a CAN enabled vehicle. OBDII port to RCPMK2 to PC. Was able to successfully read data from OBDII.

This seems to point to the Legacy OBDII adapter being the problem.