Not receiving live data from Megajolt lite junior.

General Megajolt Questions and Answers

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
simontr6
Posts: 9
Joined: Wed Oct 22, 2014 8:18 pm
Location: West Horsley, Surrey, UK.

Not receiving live data from Megajolt lite junior.

Post by simontr6 »

Good afternoon to all,

I have been registered on this site, for many years, I have a look from time to time, this is my 2nd time posting.

I converted my Challenger E Type Jaguar to the MEGAJOLT system in 2013.

The Challenger E Type, is a fibreglass replica of the E Type Jaguar series 1 OTC. The 4.2L straight 6 engine , using triple SU carbs, is from an XJ6 Series 2, The gearbox, is a 5 speed ,that comes from a XJ6 Series 3. Front and rear axles are from a XJ6 Series 2.
I have owned the car since 2005.
The car was last tuned on a rolling road in 2015, the car drives and works fine, at first there seemed to be no problem with the ignition system. In the near future, I am looking to replace the HT leads to Yamaha coil on plugs, I have looked into it, it appears it can be done by using 2 EDIS 6 Modules. But before I start to convert over, I want to retrieve the ignition map and store it on laptop then onto a memory stick. I think I have stored the ignition map on the laptop, it a simple "save as"?
I have noticed I am not getting any live data, apart from the load data, that changes when I rev the engine ,apart from the load data changing, all that is shown on my laptop is a frozen image of the ignition map. I have attached a photo, hopefully some of you tech guys can help me?
I have checked the connections from the RJ11 male plug to the DB9 female plug, all seem good.
I have checked the USB/DB9 serial male lead , my laptop states, the USB/serial lead is good and that the laptop has an up to date USB driver, for the USB/Serial lead.
Many Thanks in Advance.
Simon
Attachments
mjlj12.jpg
mjlj12.jpg (40.43 KiB) Viewed 516 times
Last edited by simontr6 on Tue Sep 01, 2020 6:58 pm, edited 1 time in total.

simontr6
Posts: 9
Joined: Wed Oct 22, 2014 8:18 pm
Location: West Horsley, Surrey, UK.

Post by simontr6 »

I have installed current firmware. I have reinstalled engine map software. I still cannot see engine revs or ignition advance on my laptop. MJLJ is working as I drove engine up to 3000 revs.
Attachments
Fullscreen capture 02072020 191127.jpg
Fullscreen capture 02072020 191127.jpg (48.97 KiB) Viewed 465 times

simontr6
Posts: 9
Joined: Wed Oct 22, 2014 8:18 pm
Location: West Horsley, Surrey, UK.

Re: Not receiving live data from Megajolt lite junior.

Post by simontr6 »

Regarding the MJLJ that I purchased and fitted in 2013. After having correspondence with Trigger wheels.com, the conclusion was, that my MJLJ, was not advancing my EDIS 6. My MJLJ was sent to Trigger wheels for testing. The MJLJ could not be repaired, so I had to purchase another MJLJ. This is the 3rd MJLJ I have purchased ,one as I said ,one was faulty , the other was fitted into another car, so I am disappointed ,that Brent P has not replied to my post. Why would the MJLJ fail? In 7 years, I have approximately covered around 7000 miles, what is the lifespan of a MJLJ?

My new MJLJ is now working, the only issue I have is the tach out does not run my digital rev counter, my meter shows appx 6vdc with the engine running.
I have read on this forum, that the PIP signal can run the rev counter. With my MJLJ disconnected I teed my rev counter wire into the PIP wire, the PIP signal drives my rev counter.
I would like to know that if I leave my rev counter connected and then plug back in the MJLJ multiplug into my MJLJ , could the rev counter being teed in, damage the MJLJ?
Would there be an advantage to connect 2 diodes , one to the MJLJ line and the other to the rev counter line after the tee? So that they would be isolated from each other?
BTW, I have a 2013 MJLJ module that does not advance ,for sale.
If you can repair it , you can have it at a fair price.

simontr6
Posts: 9
Joined: Wed Oct 22, 2014 8:18 pm
Location: West Horsley, Surrey, UK.

Re:

Post by simontr6 »

simontr6 wrote: Thu Jul 02, 2020 6:49 pm I have installed current firmware. I have reinstalled engine map software. I still cannot see engine revs or ignition advance on my laptop. MJLJ is working as I drove engine up to 3000 revs.
Just to add, my MJLJ was not working , as it was not providing an advance to my EDIS 6. My ignition system was working from my EDIS 6 only at 10 degrees advance.

simontr6
Posts: 9
Joined: Wed Oct 22, 2014 8:18 pm
Location: West Horsley, Surrey, UK.

Re: Not receiving live data from Megajolt lite junior.

Post by simontr6 »

I have rechecked the tail I wired to the Tacho out terminal on the multiplug on my MJLJ. I connected the rev counters to it They now work.
Challenger dash 2.jpg
Challenger dash 2.jpg (94.59 KiB) Viewed 85 times
Attachments
Challenger dash 1.jpg
Challenger dash 1.jpg (94.46 KiB) Viewed 85 times

brentp
Site Admin
Posts: 5955
Joined: Wed Jan 24, 2007 6:36 am

Re: Not receiving live data from Megajolt lite junior.

Post by brentp »

Hi,

Sorry to hear your original system failed; we have made a number of improvements to the new system to protect against voltage surges and other failures, so it should be more reliable for you - glad you are up and running again!
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply