RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
can output, LRWheelSpd to Speed
Author Message
Reply with quote
Post can output, LRWheelSpd to Speed 
when we custom map can channels will it override the built in channels?

I'm using harry's laptimer with an R53 Mini and it expects "Speed" so I was going to change the left rear wheel channel to simply "Speed" but I'm not having any luck with this

script is here..

https://wiki.autosportlabs.com/Mini_Cooper_R50_R52_R5#Script

I'm changing this line

rWheelId = addChannel("LRWheelSpd", 10, 0, 0, 200, "MPH")

to this line

rWheelId = addChannel("Speed", 10, 0, 0, 200, "KPH")

and took out the kph to mph correction line

but harry's laptimer is still not picking up odb speed

View user's profile Send private message
Reply with quote
Post  
Hi - If you want to force Speed to come from a Lua channel, you should disable speed in the GPS settings and name that channel "Speed". That *should* work.

Let us know what you find out!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I will try it, harry's laptimer is no longer working right due to one of the firmware updates, I'm trying to get it to work as it's the best one I've used for autocross & gopro overlay so far

View user's profile Send private message
Reply with quote
Post  
It's possible your issue might be solved with the latest app update - try the 1.8.0 app if you can.

Thanks,


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I'll check it out, the previous version was nothing like harry's laptimer it did not control gopro and auto import & overlay the gps/speed/rpm

solostorm would probably do what I want too but I've never tried it

View user's profile Send private message
Reply with quote
Post  
I tried the latest app but it does not do anything with gopro triggers/import and overlay, the data is neat but I dont need the data I need the video support, also my phone just barely runs the app, even on my nvidia tablet it's pretty slow

I disabled gps speed and setup a gps speed virtual channel instead, still not working with harry's laptimer at this point the only thing I can get harry's laptimer to do is show rpm & tps

is the bluetooth data documented somewhere so I can dig deeper?

are the virtual lua channels in the data stream the same way the ODB2 channels are? I think harry's looks for ODB2 Speed and if I can replace that with GPS speed it'll probably work

View user's profile Send private message
Reply with quote
Post  
Hi,

The direct GoPro control will be available in an upcoming firmware and app release, possibly 1.9.0 or 1.10.0 depending on how we sequence the releases. No firm ETA.

All channels, including virtual channels, are presented the same way in the data stream.

What phone are you using, and what specific areas are you experiencing slowness in the app? dashboard, launching or somewhere else?

Can you attach your current RC configuration so we can try to reproduce any issues here?

Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I still have not got harry's laptimer to pick up speed but I did get the rcp app to pick up the channels, I'm not sure why harry's wont see speed

The current app is very very slow on my phone, I picked up an nvidia tablet but it's slow in that too. Even if you add gopro start/stop and directional triggers for autocross the app still does not do overlay so I cant do anything with it until I get home.

I'm using harry's laptimer with a GPS bluetooth device until I can get racecapture to work right with it

View user's profile Send private message
Reply with quote
Post  
Thanks for the update. Watch for the GoPro trigger in an upcoming firmware version.

What specifically is slow on the Nvidia tablet - any particular screen or behavior? Can you share your config file (attach it here) - there might be something in it that's causing the slow-down - we'd love to reproduce the problem. Thanks!

Also, what brand / model of phone are you using?


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I'm only after overlay so I can view my lap after each attempt and see where I made mistakes or where I might be able to speed up. It's critical I am able to do this on site as we only have 10 min or so between laps, harry's laptimer auto imports the gopro and overlays within a couple min so I can view it before I go again.

for slowness the live screens, scrolling between them is slow, at first i thought it was my chinese phone I use for record but it's the same on this nvidia tablet.

Loading up the lua edit screen is an exercise in frustration even with no code in it, the select/cut/paste does not seem to work right either I got so mad I gave up and make the changes on my desktop instead

View user's profile Send private message
Reply with quote
Post  
Got it, thanks. Can you upload your configuration so we can attempt to reproduce the slowness issue here?

-Brent


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Found a video we made a while back. Is the dashboard performance worse than this?
https://www.youtube.com/watch?v=RDtDshLyE1U

If so, is the dashboard performance worse after RCP is connected vs before?

If your RCP config is a hassle to obtain, can you describe what you have enabled? Mini Cooper script - any analog sensor channels, etc?

Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Sorry it took so long to reply I gave up on getting the racecapture to work but the season is starting again.

I'm using the stock mini cooper R53 LUA, no extra channels. I turn off everything but speed, tps, rpm, and engine temp.

I have another script that added speed channels for harry's laptimer but his software is not picking them up

The racecapture app is very very slow, going to the script/lua screen it freezes for a while. I used podium one session last trackday I may try that again this weeekend, it does not suffer slowness as I can get to that screen and leave it run.

so far this season I have used harry's laptimer with a bluetooth obd2 adapter and a bluetooth gps adapter. Harry mentioned he will be re-visiting racecapture integration so hopefully it'll work right.

Harry's software imports gopro video, automatically syncs video with data, and exports it right on the fly so I can watch my session with data 10 minutes after the session is over all right on my phone. Racecapture software cannot do this

View user's profile Send private message
Reply with quote
Post  
Thanks for the update.

When you say "it is slow" do you mean on your phone or tablet? Is it slow switching between views on the dashboard or just on the scripting configuration page?

Can you try to go under app preferences and turn off "Session Recording"? This was a recently added feature that records your session in the background. I'm suspecting that some devices might have slower than expected disk write performance which might reflect in the overall performance of the app. If you can try this and let us know if it makes a noticeable improvement, please let us know!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum