RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
App crashes when Action button is pressed, loading data
Author Message
Reply with quote
Post App crashes when Action button is pressed, loading data 
RCP running fw 2.11 and RaceCapture app 1.90 on an Amazon Fire HD 8.

Today i drove the car to work (hasn't left the garage much) and i tried playing with the red button on the RCP unit to start and stop recording. It seems that it starts recording automatically, but i don't know why. I don't have any LUA log scripts. Based on the orange SD card LED, the button stopped recording and restarted recording, but the tablet app crashed on one of the two presses. This happened twice. After the first time i had to power cycle the tablet and the second i just killed the racecapture app and it worked when i restarted.

After that, i tried to view the recorded data in the Analysis section on the tablet app and it crashed when i tried to add a session. It crashed at the screen that would normally show a list of data sessions, but no sessions were listed, just black, and then it froze.

I haven't really played with pressing the recording button in the past, but the app has never crashed before (maybe an hour of use tops in multiple short drives and garage tests). Also new this drive are my LUA scripts for calculating gear and speed based on the E36 diff speed sensor.

Any ideas? I'll take more detailed notes and some pics of the screen if it happens again on the way home today. I've still never been able to actually review data if that's a clue.

View user's profile Send private message
Reply with quote
Post  
It crashed again on the way home. Twice right in the beginning of the trip and without pressing any buttons. Each time i had to kill the RaceCapture app. The next time i loaded the app it would freeze again before it connected to the RCP. The second restart worked both times and then it worked fine.

I also, i lied above, i do have a basic autolog LUA script running.

I have data on the RCP SDcard that looks fine.

However, whenever i try to load a session form the RaceCapture app on the tablet, it crashes. It crashes showing the window that would normally show the list of session to choose, but it shows nothing, just crashes. I tried restarting the tablet, but it seem slike the data on the tablet is corrupt or something. How can i delete it?

Thanks

View user's profile Send private message
Reply with quote
Post  
Hi Dan,

Sorry to hear of the crashing issues. I think this might be related to the other thread, and we have a bunch of fixes in the analysis mode that we need to get out in 1.9.2.

In the meantime, if you go to 'clear data' in the settings for the app (under the android settings) that will clear the datastore and let you try to import again.

We'll work to get 1.9.2 out ASAP. Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum