RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
duplicate column help please
Author Message
Reply with quote
Post duplicate column help please 
Finally got a couple of logs recorded but when attempting to open and view getting duplicate column "engine temp" warning can not open files.

I skimmed the forum, but didn't see an explanation I understood on where to find this column and how to fix it...

Computer idiot here...help please! Very Happy

View user's profile Send private message Visit poster's website
Reply with quote
Post  
I have been all through our channel set ups but can not find any "duplicates" of engine temp. hoping to log tomorrow on the water-any guidance is appreciated!

View user's profile Send private message Visit poster's website
Reply with quote
Post  
Hi,

Sorry for the late reply here!

What version of the app are you running - is it the latest 1.11.0? We made some fixes in the app around this particular issue and would be good to know if the latest resolves your problem.
Latest version: http://podium.live/software

If you're on the latest, try doing this:

1) Go to your channel configuration for Engine temperature and change it from "Engine Temp" to "EngineTemp" - this should prevent future issues.

2) Load your datalog in Notepad (don't use word). Find on the first line of the file where it says "Engine Temp" and change this to "EngineTemp" - removing the space. Save your file.

3) try importing this file again.

We'll keep an eye on this thread - let us know how it goes!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Thanks for the reply! I will check all of that and report back Very Happy

View user's profile Send private message Visit poster's website
Reply with quote
Post  
OK, so I was NOT running the latest app, am running it now but still had the same result.

My channel for engine temp already had no space so I changed it to have a space just to try something, loaded a file on notepad and made the same change there, saved it and imported again onto the app. It will now open, but I don't appear to have any values?

If I didn't screw it up, there should be a screen shot of what I see when I open the log...

Thanks a bunch-Curt

View user's profile Send private message Visit poster's website
Reply with quote
Post  
and here is what I see when I open a log file that I copied from the forum just now:

View user's profile Send private message Visit poster's website
Reply with quote
Post  
Hi, thanks for the update. Your imported log file doesn't appear to have any values because it looks like distance was not recorded in that log file. Maybe you didn't have GPS lock, and/or you weren't moving?

Press the arrow ( ===> ) icon on the line chart. This will switch it to time based view - you should then see your data.


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post Any Progress on Duplicate Columns? 
We're also seeing this issue. We' running a RaceCapture Pro MK3 and the RaceCapture App 1.11.0 on Windows 10.

I am able to view data by editing the .log file, and if I look at the file (by changing the suffix to .csv and reading it into Excel) there are no duplicate column names.

One thing that might be a factor - we swapped two analog input signals in the config. Had them swapped in the harness and changed the configs to fix it. We would have swapped them in the harness, but the MK3 connector is not user friendly like the MK1 connector was. It was one of the two signals that the app first complained about. (Ultimately it complained about several, all similar names: RFtravel, LFtravel, RRtravel, and LRtravel. I added an underbar to each and that pacified the app.

Thanks!

View user's profile Send private message
Reply with quote
Post  
Hi Doug,

Actually, the last app release had fixes for certain cases on the duplicate column error, but it looks like we have some outstanding cases.

Could we get a copy of your app's datastore.sq3 and also a copy of the logfile you're trying to import? That way we'll be able to re-create the issue you're having.

You can find the location of the datastore by looking at the top of the application log. You can link your files here, or you can email the download link to [email protected].

Thanks,


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I just emailed 3 logfiles and the datastore. Please let me know if you need anything else!

Doug

View user's profile Send private message
Reply with quote
Post  
Progress. Looks like the issue was case-sensitivity, or rather the lack of checking case.

Your datalog has the column: LRTravel; the database already has LRtravel. The RaceCapture app doesn't see this as a duplicate name, since it's considering case, but our underlying database technology is case insensitive. Our previous fix to the duplicate column name accounted for a different issue.

We should be able to compensate for this in the updated app.

Thanks!

View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum