RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 2
Goto page 1, 2  Next
RaceCapture dies during startup on Huawei P10 Lite
Author Message
Reply with quote
Post RaceCapture dies during startup on Huawei P10 Lite 
I've installed the version from the Android Play Store. I get the initial splash screen but the app dies after a few seconds.

I have it running OK on my (very) old Samsung Galaxy for now.

Please let me know if there is anything I can do to help debug this.

Rod.

View user's profile Send private message
Reply with quote
Post  
Hi,

Sorry for the inconvenience - We'll check the crash reports on this. Do any error messages show up after it crashes?


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
It just disappears ... where would I look for error messages?

View user's profile Send private message
Reply with quote
Post  
If you don't see any popup errors, you may be able to fetch a crash log using a utility.

See:

https://stackoverflow.com/questions/24407984/how-to-locate-app-crash-logs-in-android-phone

and, linked from the above article:

https://play.google.com/store/apps/details?id=org.jtb.alogcat
https://play.google.com/store/apps/details?id=crashLog.cutebabyTW&hl=sk

If you get anything useful in the crash log, please post it here. Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I captured about 9000 lines of logs in 5 seconds, so there's more data available than just this, but here are the logs from immediately before and after the crash. Let me know if there is something more specific I can look for.
Code:

10-12 09:05:42.475 17676 17696 I ServiceManager: Waiting for service SurfaceFlinger...
10-12 09:05:42.483  1384  1407 I art     : Explicit concurrent mark sweep GC freed 33781(2MB) AllocSpace objects, 13(996KB) LOS objects, 6% free, 57MB/61MB, paused 3.341ms total 244.250ms
10-12 09:05:42.877 10388 10428 W linker  : /data/data/com.autosportlabs.racecapture/files/app/lib/python2.7/lib-dynload/_sqlite3.so: is missing DT_SONAME will use basename as a replacement: "_sqlite3.so"
10-12 09:05:42.955 10388 10428 W linker  : /data/data/com.autosportlabs.racecapture/files/app/lib/python2.7/site-packages/sqlalchemy/cprocessors.so: is missing DT_SONAME will use basename as a replacement: "cprocessors.so"
10-12 09:05:43.078 10388 10428 W linker  : /data/data/com.autosportlabs.racecapture/files/app/lib/python2.7/site-packages/sqlalchemy/cutils.so: is missing DT_SONAME will use basename as a replacement: "cutils.so"
10-12 09:05:43.083 10388 10428 W linker  : /data/data/com.autosportlabs.racecapture/files/app/lib/python2.7/site-packages/sqlalchemy/cresultproxy.so: is missing DT_SONAME will use basename as a replacement: "cresultproxy.so"
10-12 09:05:43.377  1384  1384 I TrafficMonitor: update:rxPkts:2,txPkts:1,rxBytes:136,txBytes:64
10-12 09:05:43.377  1384  1384 I TrafficMonitor: start expired. level:-1
10-12 09:05:43.377  1384  1384 I TrafficMonitor: gettimer:interval=2000
10-12 09:05:43.456   471   471 E ServiceManager: try to find service failed, not allowed access from isolated processes.
10-12 09:05:43.456 26287 26308 I ServiceManager: Waiting for service SurfaceFlinger...
10-12 09:05:43.476   471   471 E ServiceManager: try to find service failed, not allowed access from isolated processes.
10-12 09:05:43.476 17676 17696 I ServiceManager: Waiting for service SurfaceFlinger...
10-12 09:05:43.500 10388 10428 I python  : [ERROR  ] [Main        ] crash caught: Reference is 5eb9700e378b4164b7800bbe846f6be8
10-12 09:05:43.501 10388 10428 I python  : [CRITICAL] [Traceback (most recent call last)]
10-12 09:05:43.501 10388 10428 I python  :   File "/home/brent/git-projects/RaceCapture_App/.buildozer/android/app/main.py", line 608, in <module>
10-12 09:05:43.501 10388 10428 I python  :   File "/home/brent/git-projects/RaceCapture_App/.buildozer/android/app/main.py", line 168, in __init__
10-12 09:05:43.501 10388 10428 I python  :   File "/home/brent/git-projects/RaceCapture_App/.buildozer/android/platform/build/dists/racecapture/private/lib/python2.7/site-packages/kivy/app.py", line 780, in user_data_dir
10-12 09:05:43.501 10388 10428 I python  : OSError: [Errno 2] No such file or directory: '/sdcard/racecapture'
10-12 09:05:43.501 10388 10428 I python  :
10-12 09:05:43.538  1384  1523 E WifiConfigManager: updateConfiguration freq=2452 BSSID=f4:f2:6d:b4:35:80 RSSI=-38 "RADNet"WPA_PSK
10-12 09:05:43.601 10388 10428 I python  : Sentry is attempting to send 1 pending error messages
10-12 09:05:43.601 10388 10428 I python  : Waiting up to 10 seconds
10-12 09:05:43.601 10388 10428 I python  : Press Ctrl-C to quit
10-12 09:05:44.236 10388 10428 I python  : Python for android ended.
--------- beginning of crash
10-12 09:05:44.246 10388 10388 F libc    : Fatal signal 11 (SIGSEGV), code 1, fault addr 0x4 in tid 10388 (abs.racecapture)
10-12 09:05:44.247   383   383 W         : debuggerd: handling request: pid=10388 uid=10141 gid=10141 tid=10388
10-12 09:05:44.360   489   489 E Thermal-daemon: [pa_0] temp_new :31  temp_old :30
10-12 09:05:44.362  1844  2246 I ThermalService: Receive temperature change, type: 1, temp: 31 from thermald
10-12 09:05:44.362  1844  2408 W HwThermalStateManager: warning: no config thermal type:1 temperature:31
10-12 09:05:44.362  1844  2408 I LowBatteryManager: Only handle msg event!
10-12 09:05:44.362   489   489 E Thermal-daemon: Report temperature: [pa_0] temp :31  report_threshold:1
10-12 09:05:44.364   489   489 E Thermal-daemon: [ap] temp_new :34  temp_old :35
10-12 09:05:44.364  1844  2481 I ThermalService: Receive temperature change, type: 0, temp: 34 from thermald
10-12 09:05:44.365   489   489 E Thermal-daemon: Report temperature: [ap] temp :34  report_threshold:1
10-12 09:05:44.365  1844  2408 I LowBatteryManager: Only handle msg event!
10-12 09:05:44.441 10439 10439 F DEBUG   : *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
10-12 09:05:44.442 10439 10439 F DEBUG   : Build fingerprint: 'HUAWEI/WAS-LX3/HWWAS-H:7.0/HUAWEIWAS-LX3/C605B120:user/release-keys'
10-12 09:05:44.442 10439 10439 F DEBUG   : Revision: '0'
10-12 09:05:44.442 10439 10439 F DEBUG   : ABI: 'arm'
10-12 09:05:44.442 10439 10439 F DEBUG   : pid: 10388, tid: 10388, name: abs.racecapture  >>> com.autosportlabs.racecapture <<<
10-12 09:05:44.442 10439 10439 F DEBUG   : signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x4
10-12 09:05:44.442 10439 10439 F DEBUG   :     r0 00000001  r1 00000001  r2 00000000  r3 00000001
10-12 09:05:44.442 10439 10439 F DEBUG   :     r4 e54f7780  r5 00000000  r6 00000000  r7 d60c17d0
10-12 09:05:44.442 10439 10439 F DEBUG   :     r8 f365b008  r9 f2484f00  sl f2484f8c  fp ffb48dc4
10-12 09:05:44.442 10439 10439 F DEBUG   :     ip d607ec24  sp ffb48c00  lr d5fc63e9  pc d5fbc0aa  cpsr 800f0030
10-12 09:05:44.444 10439 10439 F DEBUG   :
10-12 09:05:44.444 10439 10439 F DEBUG   : backtrace:
10-12 09:05:44.452 10439 10439 F DEBUG   :     #00 pc 000c00aa  /data/app/com.autosportlabs.racecapture-1/lib/arm/libpython2.7.so (PyThreadState_New+93)
10-12 09:05:44.452 10439 10439 F DEBUG   :     #01 pc 000ca3e5  /data/app/com.autosportlabs.racecapture-1/lib/arm/libpython2.7.so (PyThread_acquire_lock+76)



View user's profile Send private message
Reply with quote
Post  
This could be the culprit:

10-12 09:05:43.501 10388 10428 I python : OSError: [Errno 2] No such file or directory: '/sdcard/racecapture'

Did you do a conventional install, or did you change the install location?


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I just installed the build that's in the playstore. Nothing more.

View user's profile Send private message
Reply with quote
Post  
I have the sdcard set as the default storage location on this phone.

View user's profile Send private message
Reply with quote
Post  
Is that different than the factory default location?

View user's profile Send private message Send e-mail
Reply with quote
Post  
Yes. The factory setting is "Internal Storage".

View user's profile Send private message
Reply with quote
Post  
Is it feasible for you to temporarily set it to 'internal storage', then re-install and try running again?

Thanks,


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
It's a big pain to change. I think it's almost a factory reset. I'll double check this, I may be able to clone my SD card and try it on the clone, but don't count on me getting this to work. Either was I won't be able to change this till next week if at all.

View user's profile Send private message
Reply with quote
Post  
Got it. Does your phone allow apps to be individually moved to internal storage?

I typically see the opposite, where the phone offers the option of moving an app to external storage, so maybe it's possible to configure it this way on your phone.

Thanks,

View user's profile Send private message Send e-mail
Reply with quote
Post  
So far, I've not been able to find such an option. I have another phone I can experiment with a bit more, but its not with me right now. (I'm away racing for the weekend now, so I won't be much help till next week).

If you figure anything out in the meantime let me know.

View user's profile Send private message
Reply with quote
Post  
We'll post here if we have a chance to take a look at it. Thanks for working with us through it!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 2
Goto page 1, 2  Next
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum