RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Can't disable predictive timing
Author Message
Reply with quote
Post Can't disable predictive timing 
Hi guys,

For some reason, I can't disable predictive timing in my RCP Pro MK3. I turn it off on the app (windows, raspberry pi), write to the RCP, but it isn't disabled. If I read the data from RCP, it's back to on.

I tried to disable it directly on the txt (.rcp) file, by putting 0 in "sr" field under predTime, but didn't work either.


_________________
--Paulo
View user's profile Send private message
Reply with quote
Post  
Here is a quick video that I recorded to show the problem:

https://youtu.be/rFhdf8CDEu0

I'm not sure if this thread should be here or in app section.


_________________
--Paulo
View user's profile Send private message
Reply with quote
Post  
Thanks, got it logged here:
https://github.com/autosportlabs/RaceCapture-Pro_firmware/issues/957

We'll see if we can get it into the next release.


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Should be fixed in the 2.13.0 firmware / 1.12.0 app release when it is available in beta later this week.


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Brent,

Looks like "predictive timing" was fixed, but now the problem happens to "race timing" option. It will show always "off", though.


_________________
--Paulo
View user's profile Send private message
Reply with quote
Post  
Hi, can you clarify if you are using the beta 2.13.0 firmware and also the 1.13.0 app?


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Yes, I am.


_________________
--Paulo
View user's profile Send private message
Reply with quote
Post  
Hi,

We cannot re-produce a problem you described.

These combinations are valid:

Race Timing On / Predictive timing Off
Race Timing On / Predictive Timing On
Race Timing Off / Predictive Timing Off

Every time we tested this, we wrote the settings back to the unit and read the settings back, confirming the setting is retained.

If you still see this problem, can you post a video of it happening so we can see what is going on? when you test, be sure to write the setting before reading it again.

Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Hi,

Looks like the issue happens when "Predictive Timing" setting is changed. When "Race Timing" is "on" and "Predictive Timing" is changed from "off" to "on" or from "on" to "off", "Race Timing" is set to "off" as well:

I recorded a video:

https://youtu.be/_WAbjLwZe2w


_________________
--Paulo
View user's profile Send private message
Reply with quote
Post  
thank you for that.

Are you seeing it happen on Android or Windows?

-Brent


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Windows and Raspbian. I didn't try to reproduce on Android.


_________________
--Paulo
View user's profile Send private message
Reply with quote
Post  
We did see it reproduce once on RPi, not on windows or Linux. Very strange. We've logged the issue to inspect more.

If you do a read back and see race timing was incorrectly turned off, could you try shutting down the app and power-cycling, and then re-running the app with a fresh read? Would be curious if the setting was actually incorrect inside of RaceCapture, or if it was an app glitch.

Thanks!!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Alright, if I shut down everything (app, RCP itself) and re-read the config in a new app section, after race timing incorrectly turned off, it will still appear as "off".


_________________
--Paulo
View user's profile Send private message
Reply with quote
Post  
Thank you. That helps to know!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum