RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
RCP3 Difficulty getting in OBD-II/Can data
Author Message
Reply with quote
Post RCP3 Difficulty getting in OBD-II/Can data 
So I had been working on serial input from innovate gauges but have put that on hold. Now I am trying to simply integrate my system into my Mazda3.

If I use my cable hooked up to my Racecapture/Track I get data coming in easily and have previously used this setup to log hdpe sessions.

I now use that same stock cable to connect to my RCP Pro mk3 and I am not getting any data into the app and the can light has never lit up once. My logs show that Can 0 and 1 connect succesfully but if I utilize the https://wiki.autosportlabs.com/CAN_Bus_logger script it just keeps on telling me there is no can data.

I have the most recent versions of the software on my windows laptop and firmware on the unit. I did a hard reset via putty and still nothing.

What am I missing here that would cause me to not receive data?

View user's profile Send private message
Reply with quote
Post  
Hi,

When you use the CAN bus logger, it only shows the stream of data coming in - for example, from a direct source of CAN data.

Unless OBDII is turned on and actively querying data, you would not see OBDII data streaming using that logger. You might see out-of-band CAN traffic from the ECU, depending on the manufacturer.

On your RCP3 you'll want to double check the following:

* CAN bus turned 'on'
* set to 500K baud
* termination 'on'
* OBDII turned 'on' and one example channel added (RPM)

That's a good basic way to test if OBDII and CAN bus is working. You could try it on different cars, as well.

Thanks - Let us know what you find out


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I have tried this on both a 2012 Mazda3 and a 2011 Fiesta with the same results.




View user's profile Send private message
Reply with quote
Post  
Hi, sorry for the late reply.

Can you post your configuration file here as an attachment so we can take a look at it? There might be a hidden setting causing a problem.

Thanks,


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
which configuration file do you need?

View user's profile Send private message
Reply with quote
Post  
Possibly this one?




mazda3conf.txt
 Description:

Download
 Filename:  mazda3conf.txt
 Filesize:  13.58 KB
 Downloaded:  6 Time(s)

View user's profile Send private message
Reply with quote
Post  
Hi, I checked your configuration and it looks sane.

We might need to check out your unit for a possible issue. Can you contact [email protected] and we can take it from there?

Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum