RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 2 of 2
Goto page Previous  1, 2
RaceCapture Track 2.13 Beta Bugs
Author Message
Reply with quote
Post  
It did the last time I tried it, yes.
FWIW, today I installed my Pro 3 in my other car. Using firmware 2.13 my 4 analog sensors and RPM trigger works fine. But I can't get any ODB2 sensors. I really only want to know and be able to log IAT as this is important for tweaking the engine to the proper AFR. I could put a temp sensor in the airflow but it would be nice if that $99 cable did something. Smile

View user's profile Send private message
Reply with quote
Post  
As a test, you can downgrade your RCP to 2.12.0 to see if your OBDII adapter works. that would be a good datapoint for us. Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
OK, can I use the same config or do I have to start from scratch?

View user's profile Send private message
Reply with quote
Post  
If you're only doing a diagnostic test, just use the factory default config, and add one OBDII channel (like RPM) for testing.

Likewise, when you go back to 2.13.0, you can do the same isolated test (one OBDII channel) to get a very precise comparison.

Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
First test: Loaded 2.12, factory config, setup IAT and Engine Temp, both worked perfectly.
Second test: Added working config created under 2.13, removed IAT & ENgine temp, Reloaded them, both worked.

On to 2.13 reload and try with factory config

View user's profile Send private message
Reply with quote
Post  
Loaded firmware 2.13, added IAT and engine temp ODB2, made sure that CAN was On, 500khz, Mapping off, ODB2 on.

Nothing.....Zeros

View user's profile Send private message
Reply with quote
Post  
Thanks. So, in summary, your 2.13.0 configuration loaded into 2.12.0 firmware worked OK for OBDII.

Will note and investigate. Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Yes, it appears that it's something in the 2.13 firmware that is blocking the ODB2 reads.
But I need 2.13 as that's the one that allows control of the GoPro's, at least with the RCP, correct?

View user's profile Send private message
Reply with quote
Post  
2.13.0 we added native go-pro control.

If you need to use 2.12.0, the old way still works, with the Lua script:
https://wiki.autosportlabs.com/RaceCapturePro2_GoProWiFi


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Just to confirm, in order for a config created under 2.13 with non-working ODB2 inputs to work after reloading 2.12, you have to delete the ODB2 inputs and reload them for them to work. That is, they must be created within 2.12 firmware.

View user's profile Send private message
Reply with quote
Post  
Hi,

Just confirming; are you saying that a config saved by a system with 2.13.0 firmware will not work when loaded into 2.12.0, and that you have to remove and re-add the channel to get it to work?


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Yes, exactly. Confirmed this morning when I took the unit back to 2.12 and reloaded the config I created under 2.13 with all of the other sensors working. When I delete the ODB2's and reload they work fine but do not work when first loaded. Everything else seems to work correctly.

View user's profile Send private message
Reply with quote
Post  
Thanks, will check that too.


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 2 of 2
Goto page Previous  1, 2
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum