RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 5 of 5
Goto page Previous  1, 2, 3, 4, 5
Raspberry Pi support - enables a hard-wired, dedicated dash
Author Message
Reply with quote
Post  
Thanks for the update.

Can you explain further w/r/t "Lose Connection" ?

If RCP loses GPS (e.g. you unplug the GPS antenna, for example. to force the issue)- and you lose all satellite) are you saying the RPi loses connection with RCP?

This should not happen *at all* - you should be able to connect to RCP regardless of the GPS status- and we've never seen that here. But if you can reproduce it reliably we'd be keen to fix it.

Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
When initially powering on RaceCapture (RC) device via USB to the raspberry Pi the GPS status indicator on the top right of the screen will blink red and green while viewing the data channel screen.

Until the GPS status indicator stops blinking between red and green, the USB comm with the RaceCapture continually resets.

Once the GPS status indicator stops going red and starts blinking green then the USB comm connections seems to become stable and data on the screen continually updates.

If i do a warm start, ie. don't power down the Pi or RC then i don't get the issue. Its only from a cold boot.

Steps to reproduce are:
1. Power down the Pi and the RaceCapture
2. Ensure RaceCapture is plugged into USB port on Pi
3. Plug power into Pi and let boot up
4. Launch RaceCapture exec=sudo "opt/racecapture/run_racecatpure.sh"
5. In RC goto Dashboard
6. Observe behavior above.

View user's profile Send private message
Reply with quote
Post Screen Going Blank 
I should know this, but some how I can't remember how to do this, what are the steps to keep the screen on the Pi from turning off while running RaceCapture?

View user's profile Send private message
Reply with quote
Post  
Thanks.

That description helps. So it is not actually related to GPS; it is an artifact of the connection being lost and re-established - the GPS icon only goes green if we have an active connection with GPS lock.

Try doing a factory reset - use minicom to issue the resetConfig on RCP's command line interface and see if that makes a difference. Be sure to save your current configuration, naturally.


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post Re: Screen Going Blank 
timlhunter wrote:
I should know this, but some how I can't remember how to do this, what are the steps to keep the screen on the Pi from turning off while running RaceCapture?


Never mind I found it. Have to add

[SeatDefaults]
xserver-command=X -s 0 -dpms

to the /etc/lightdm/lightdm.conf file

View user's profile Send private message
Reply with quote
Post  
How do I use minicom to issue the resetConfig on RCP's command line interface?

View user's profile Send private message
Reply with quote
Post  
timlhunter wrote:
How do I use minicom to issue the resetConfig on RCP's command line interface?


Anyone know how to do this?

View user's profile Send private message
Reply with quote
Post  
Hi, Sorry for the late reply.

Ensuring the app is not running, run minicom on linux and configure it to connect to /dev/ttyACM0.

Once connected, press <enter> to see a list of CLI options.

type 'resetConfig' and press enter. This will reset to factory defaults.


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post RPI UPS 
Having problems with my RPi voltage, I have a 12v-5v5a power source, but when i hit the starter, RPi restarts. So, i ordered one of the UPS Pico units but they wont/cant ship a LiPo battery overseas. so my question is, now that i am searching hobby stores for a battery, what size should i get? the LCD i have uses 550ma. would a 3.7v 4500mah be sufficient or should i go 8000mah?

View user's profile Send private message
Reply with quote
Post Re: RPI UPS 
PS14 wrote:
Having problems with my RPi voltage, I have a 12v-5v5a power source, but when i hit the starter, RPi restarts. So, i ordered one of the UPS Pico units but they wont/cant ship a LiPo battery overseas. so my question is, now that i am searching hobby stores for a battery, what size should i get? the LCD i have uses 550ma. would a 3.7v 4500mah be sufficient or should i go 8000mah?


"I am using a 10000mAh battery with no issues. I am using the re-fuel model JS-PBQC10 no: RF_PBQC10

View user's profile Send private message
Reply with quote
Post  
That's a nice little unit, and only $25 online! question, I see it has a power button. do you have to turn it on/off every time? and where did you run the usb cable to?

View user's profile Send private message
Reply with quote
Post  
PS14 wrote:
That's a nice little unit, and only $25 online! question, I see it has a power button. do you have to turn it on/off every time? and where did you run the usb cable to?


It turns off by itself when the USB cable is disconnected. Also you do have push the power button to start it up.

I ran the USB cable to PI and used the power from the OBDII port to run the race capture box

View user's profile Send private message
Reply with quote
Post  
oh, ok. so you must be charging it up in the shop then putting in in for race day? I plan to use the Pico to automatically charge it while the car is running.

View user's profile Send private message
Reply with quote
Post  
PS14 wrote:
oh, ok. so you must be charging it up in the shop then putting in in for race day? I plan to use the Pico to automatically charge it while the car is running.


Yes, and I top it off in between sessions.

View user's profile Send private message
Display posts from previous:
Reply to topic Page 5 of 5
Goto page Previous  1, 2, 3, 4, 5
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum