RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Predictive Lap time acting out
Author Message
Reply with quote
Post Predictive Lap time acting out 
I think (not positive) that since we install version 13, we are having problems with the predictive lap timer delta. It gets stuck in a high value, as if it got a best time of 0 (maybe) so that any lap is obviously slower.

Watching a video we recorded at a race today you will see that the delta is moving by itself even with the car in the garage. Also the predicted time flashes to 20:00:0 once in a while.

Take a look at https://youtu.be/yyx2eEDGT64 minute 46 to 48.

You can also see it stuck, almost the entire race, at https://youtu.be/zzxhqbOMlmY

Let me know if we are doing something wrong.

On an older related subject:
We are still experiencing high (over 1 or 2 seconds that real) values for the predicted time, even with excellent GPS reception. It continues happening normally a few seconds before the finish line and then it corrects.

View user's profile Send private message
Reply with quote
Post Predictive Lap time acting out 
Same behavior today.
You can watch live at https://youtu.be/jhUAMbhw2ek
Delta time stuck.

View user's profile Send private message
Reply with quote
Post Predictive Lap time acting out 
Changed GPS to 10 Hz and it was better in last race.

View user's profile Send private message
Reply with quote
Post  
Thanks for the update, glad it's working better for 10Hz. What GPS rate did you have before?

10Hz is the ideal balance for performance / accuracy. A bit more detailed here:
https://wiki.autosportlabs.com/RaceCapture_GPS


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I was using 25Hz.

View user's profile Send private message
Reply with quote
Post  
Got it. A good resource on GPS is here: we updated it with some information on how to interpret the GPS stats channels as well:
https://wiki.autosportlabs.com/RaceCapture_GPS


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I know you guys have been reluctant to check the preditive lap time algorithm, but it definately misbehaves.

In many ocasions it is erratic right before crossing the finish line and corrects as soon as you cross it.

You can see the behaviour in the video: https://www.youtube.com/watch?v=pqbIjQRjIHs Notice that most of the time the prediction is very much off the real time. I think that should be measure of the reliability of the algorithm.

It also seems to fix itself in the fastest lap which means it is very optimistic when the lap starts and becomes more realistic as one progresses. It seems to be addiding the time that is left from the fastest lap to the current time.

This video will give you an idea, as the previous driver (not in the video, had set a fastest lap of 1:47:601 and this new driver laps around 1:51. Not withstanding the prediction is low during the entire lap.

We have tried 25Hz and 10Hz and GPS reception was good that day.

We have also a Vbox in the same car that does a much better job; not live unfortunately.

View user's profile Send private message
Reply with quote
Post  
Hi,

Thanks for the post. Not reluctant, we do have it on our list of issues to address. What we're lacking are some data files with laps that clearly show it happening. Would you be able to attach some log files so we can catch it in the act?

Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I did before but you guys answered that it was related to GPS accuracy and I gave up.

I am no longer logging data since we installed a VBOX and their analysis software is better. So we are using Racecapture for telemetry only now.

I can insert a card next time and capture some data for you, but the behavior is recurrent.

View user's profile Send private message
Reply with quote
Post  
Gotcha. If you have old log files where this occurred we'll take a look at that as well. Just send us what you have. Thanks!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum