AnalogX with AIM MXG 1.2

Q&A for AnalogX Analog to CAN interface. <a href="https://wiki.autosportlabs.com/AnalogX">Installation and Operation Guide</a>
Post Reply
jeffmcaffer
Posts: 31
Joined: Sat May 07, 2016 9:26 pm

AnalogX with AIM MXG 1.2

Post by jeffmcaffer »

I'm moving a bunch of RaceCapture sensors to a car with an AiM MXG 1.2 and picked up an AnalogX to connect as a CAN expansion module. Unfortunately the MXG does not seem to recognize the AnalogX. I have verified the connections, the AnalogX has 3.3v at the pads on the back and that the sensors are powered (5V) and the signal voltage is varying as the sensor is varied.

It seems like the AnalogX is simply not being discovered on the CAN bus. I tried both 500K and 1M baud rates and am using the default BASE ID. In RaceStudio 3 I added a CAN expansion and selected the AIM "Channel Expansion" module (the only real choice). The UI has a facility to set the "Expansion serial number". Not 100% sure what that is but I set it to the BASE ID (in decimal as the UI does not accept alphas). The RaceStudio "Get Expansion Serial Number" operation does not detect any "compatible expansion modules".

Any thoughts on what's wrong or how to debug?

Jeff
Pro3 #24

jeffmcaffer
Posts: 31
Joined: Sat May 07, 2016 9:26 pm

Post by jeffmcaffer »

Bump? @brentp would love to get this wired up before the race season. Pointers much appreciated.

Jeff
Pro3 #24

brentp
Site Admin
Posts: 6281
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Hi, If you can verify AnalogX is broadcasting CAN data by testing with RaceCapture (e.g. the CAN logging script, or by mapping channels) or using a separate CAN bus logger, then you may need to chat with AIM directly. You can also ensure termination is set correctly on the ends of the network and verify those settings.

Hope this helps,
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply