Hard cut limiter not working.

Report problems on the Megajolt firmware and PC software

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
Posts: 5
Joined: Fri Feb 05, 2021 8:33 pm

Hard cut limiter not working.

Post by Kyle_TSI5 »

Hello all,

I’m in need of some help, sense emails aren’t working. I am running the MK2 unit, and overall am having great results. Up until yesterday when I had realized my limiter is no longer working, where it has previously in the past. (Loud bangs and pops, no more rev’ing) Currently, it it’s the soft limiter, goes to 0 degrees advance, then continues to rev past the hard limiter. No matter what range it is set. Same result with ignition map 1 and 2. I’m fully aware of the committing to flash feature and what not, so I don’t think I’m stepping on my toes there. More info, the limiter shows correctly on screen, rpm and command timing are correct, and the wiring is correct with appropriate gauge. Everything was working perfectly up until yesterday. Have there been cases of bad units? Software glitches? I’ve tried writing a new map from stock, with no luck either.

Any tips/tricks/advice would be much appreciated.

Posts: 1
Joined: Fri Sep 16, 2022 5:03 pm

Re: Hard cut limiter not working.

Post by Minimauritius »

Having the exact same problem.
Any help would be greatly appreciated

Site Admin
Posts: 6281
Joined: Wed Jan 24, 2007 6:36 am

Re: Hard cut limiter not working.

Post by brentp »

It could be that the hard rev limiter circuit internally is damage. If within the 1 year warranty, it may be possible to repair if not due to improper installation / use. Please contact [email protected] for more help.
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply