RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 2
Goto page 1, 2  Next
New V3 configurator
Author Message
Reply with quote
Post New V3 configurator 
Help Guys, ive download the latest V3.2 Configurator but im unable to get it to communicate with my MJ unit.

As soon as i plug the unit in ( serial cable not usb ) it comes up with a msg Unsupported controller version. Ive download the new firmware ( bit unsure what to do with it once ive downloaded it )

I also get the MSG on the bottom of the display ‘Timeout Reading Runtime Data’

The old software tuner was fine so what am i doing wrong. Crying or Very sad




prob1.JPG
 Description:
 Filesize:  32.72 KB
 Viewed:  17045 Time(s)

prob1.JPG


View user's profile Send private message
Reply with quote
Post  
This is by design. You can download the V3.0.0 configuration software to use with the version of the firmware you currently have.

As you've gathered the V3.2.x configuration software is designed to work with the newer firmware; you can also upgrade the firmware to the latest version. See the upgrade guide here for the steps to do the upgrade:

http://www.autosportlabs.net/3.1.0-2.7.0_upgrade_guide

(Just substitute V3.2.1 wherever it says 3.1.0 -- I haven't updated the documentation to reflect the released version).

Hope this helps,


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Its been a while since i used the CMD page brent, i get as far as 'Waiting for HC08 reset ACK...' then it just sits there waiting

View user's profile Send private message
Reply with quote
Post  
That's correct!

The MJLJ should be powered off before you issue the "hc08sprg....." command.

...then when you see the 'Waiting for HC08 reset ACK...' power up the MJLJ...

...and the CMD window will show some status values and ask whether you want to program the unit [y/N]

..press y and then Return...

...and the new firmware will be loaded.

Make sure you save your existing map on the MJLJ as it will be overwritten with the new firmware

View user's profile Send private message
Reply with quote
Post  
Thas what im doing guys, soon as the 'Waiting for HC08 reset ACK...'msg appears i power up the MJLJ unit but nothing happens it just keeps waiting.

Does this look ok ??




prob2.JPG
 Description:
 Filesize:  26.79 KB
 Viewed:  17026 Time(s)

prob2.JPG


View user's profile Send private message
Reply with quote
Post  
What type of serial connection are you using for your computer? The programming utility is known to have problems with certain USB-Serial adapters.

You might want to try using a computer with a standard serial port and power the unit with a fresh 9V battery.

Report back,


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Also - its highly recommended you use the 3.2.1 firmware instead of 3.2.0; see the other post in this forum.

Regards,


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Im using a serial cable with a 12v battery, ive tried bith firmware. Ill charge the battery as its been sitting here ofr a few months, it working fine with the old style software.

Spence

View user's profile Send private message
Reply with quote
Post  
Charged the battery over night, and tried it before i went to work, still doing the same. HELP Confused Confused

View user's profile Send private message
Reply with quote
Post  
OK - back to basics for a moment as you seem to be having trouble with updating the firmware....

Does it (still) work in-vehicle?

What version of firmware do you have in the MJLJ at the moment?

You say that the old Configurator was fine - does it still work with that? - do you still have the equivalent Configurator to try? ... you can have many versions of the Configurator installed on your PC at once - I have 4! .. and you can download the older Configurators from http://www.autosportlabs.net/MJLJ_V3_Downloads

Have you got/can you borrow another USB adapter?
EDIT: what USB adapter do you have - look in My Computer|Properties|Hardware|Device Manager|Universal Serial Bus Controllers - does it give a clue that you have a FTDI or Hugepine adapter?

Report back...

View user's profile Send private message
Reply with quote
Post  
MartinM wrote:
OK - back to basics for a moment as you seem to be having trouble with updating the firmware....

Does it (still) work in-vehicle?

What version of firmware do you have in the MJLJ at the moment?

You say that the old Configurator was fine - does it still work with that? - do you still have the equivalent Configurator to try? ... you can have many versions of the Configurator installed on your PC at once - I have 4! .. and you can download the older Configurators from http://www.autosportlabs.net/MJLJ_V3_Downloads

Have you got/can you borrow another USB adapter?
EDIT: what USB adapter do you have - look in My Computer|Properties|Hardware|Device Manager|Universal Serial Bus Controllers - does it give a clue that you have a FTDI or Hugepine adapter?

Report back...



Does it (still) work in-vehicle? Yes

What version of firmware do you have in the MJLJ at the moment? How can i tell what version thats in it

You say that the old Configurator was fine - does it still work with that? Yep , i can get the config from the MJL unit and write to the MJL using the old configurator

Have you got/can you borrow another USB adapter?
EDIT: what USB adapter do you have - look in My Computer|Properties|Hardware|Device Manager|Universal Serial Bus Controllers - does it give a clue that you have a FTDI or Hugepine adapter?

Im using a 9pin serial cable into my serial port on my PC no usb adaptor being used.


Its like the pc cant see the MJL unit whilst in the CMD screen.


Spence

View user's profile Send private message
Reply with quote
Post  
Sorry Spence - I missed the bit in your first post (and later ones as well!) about using a real serial port Embarassed

So your screen dumps show that you have V3.0.0 firmware in the MJLJ and you're trying to run the V3.2.0 configurator - which doesn't work - and trying to load firmware V3.2.0 into the MJLJ on COM3. And as Brent says, you should probably be going to V3.2.1 firmware and V3.2.1 Configurator, but that's not the issue here.

If the V3.0.0 Configurator downloads and uploads maps OK then I'm a bit stuck for ideas Sad apart from:

- your MJLJ isn't on COM3. hc08sprg.exe will report an error if the COM port doesn't exist, so that seems OK. Are you really, really sure the MJLJ is on COM3 Confused

- I have had problems with the reset ACK not being recognised occasionally. It almost seems that I'm not connecting the power quick enough (ie it needs a rapid application of power, which defies a lot of logic). If that happens I just Control-C the DOS command and rerun it - it invariably works fine next time I power up the MJLJ while the PC is waiting for the reset ACK

I'll keep thinking....

View user's profile Send private message
Reply with quote
Post  
Agree with martin, the programming tool seems a bit finicky at times. Sometimes it doesn't take on the first try.

So evidently you've removed the mjlj from the vehicle and you are trying to program it on your bench using your desktop pc and a standard serial port. And, on the same pc the V3.0.0 config software works fine on Com3?

Under the 'how to' section above, you will find the troubleshoooting section. Follow the instructions for using hyperterminal.

Watching the screen on hyperterminal, power cycle the controller. What you should see is one character show up on the screen everytime you power cycle- this would be the signal to the programming software that its ready to program.

Of course you could try the other troubleshooting steps to verify communications.

hang in there, let us know what you find out!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Woo Hoo i got there in the end. I've installed the latest firmware and its all works.

Not really sure what i did in the end, just sat infront of the computer trying over and over again with different com ports.


Thanks for all your help guys. Time for the rolling road now.

Heres the engine that the MJLJ is sparking. Tuned 2L Zetec on Bike carbs.




CIMG0218.JPG
 Description:
 Filesize:  78.65 KB
 Viewed:  16739 Time(s)

CIMG0218.JPG


View user's profile Send private message
Reply with quote
Post  
Well persevered!

Which bike carbs are they and what manifold did you use?

Martin

View user's profile Send private message
Display posts from previous:
Reply to topic Page 1 of 2
Goto page 1, 2  Next
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum