RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 7 of 7
Goto page Previous  1, 2, 3, 4, 5, 6, 7
Megajolt Android tuning app
Author Message
Reply with quote
Post  
Ah, so I need to set the BT adaptor up to 4800 baud then. Will try that later today.

Edit:

tried it... nothing works. Baud on BT module now at 4800.

I have a Bluetooth adaptor on my PC and it will pair with my module, but it seems to assign 2 com ports within windows... one incoming and 1 outgoing. Using 'putty' to try and communicate I get nothing at all through either port, which I guess makes sense as I can't see both ports at the same time. The configurator software also cannot talk to it and crashes completely (Windows 7 64bit)... guessing that's because of the 2 ports issue aswell. Surely it can do 2 way comms on 1 port, but I can't for the life of me work out how to do it.

My phone will pair with it ok too, and using a terminal app on there I also get nothing at all from it.

I must be doing something wrong.

What commands from the API do I send via Terminal over the Bluetooth com port to get responses from the MJLJ? I assume a simple V should return the version number etc.?

I can communicate with the BT module over the RS232 through the MJLJ and 'AT' returns 'OK' so I assume the module itself is working in that ed with the Bluetooth stuff now.

Managed to get respnses to S command through the DB9 port so getting cloeer to understanding it. Steep learning curve.

View user's profile Send private message
Reply with quote
Post  
I'm issuing the same problems as capri_turbo, only the difference is that I'm running on a V4 MegaJolt unit.

I've hooked up the bluetooth module to the MJ. LED on bluetooth module is flashing. I can pair with my phone and in the app, I can connect to the MJ. LED stops blinking and stay solid.

However, I cannot download the ignition mapping from the MJ and sucking on the map sensor doesn't result in a movement of the gauges.

After disconnecting I continually get the message that the MJ is disconnected, even when I reconnect.

As far as I know, my MJ is a V4. I have build it myself and it has run successfully for years now.

I used my phone, a Sony Xperia Z1 Compact with Android 4.3 and the bluetooth module identifies as HC-06

View user's profile Send private message
Reply with quote
Post  
I get an error when trying to connect to the MJ that states I need to select a BT connection. I have already done that and the correct BT module is selected. The BT settings for the tablet show 2 pairings, but the icon is not blue (is it not connected then?)...one is my OBDII and the other is the MJ. Is there somewhere else to also make the connection?

View user's profile Send private message
Reply with quote
Post  
Any progress with the BT tuner? Is support for the V3 in the pipeline.

View user's profile Send private message
Reply with quote
Post  
I now have Bluetooth comms working fine between my PC and my V3 MegaJolt... it took a while to get it working as I had some confusion over com ports and the way Windows installs the blutooth stuff, but it works just great.

As per my post in the QA section, will the PC configurator software run on Windows phone or tablet?

View user's profile Send private message
Reply with quote
Post  
After a lot of messing about I have successfully implemented bluetooth comms on my V3 and using a windows based tablet, (Linx10) which runs a full version of windows 8.1 the original windows configurator program runs and communicates over the bluetooth perfectly.

I'm going to build a better bluetooth module that plugs directly into the serial port soon... some hardware mods required in the form of wire links which will require a special lead from the 9 way for normal comms will see this project being very neat and simple to implement.

View user's profile Send private message
Reply with quote
Post  
Nice, please share pictures when you do!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Got this done sooner than expected...

Hardware mods... +5V from Vref to pin 1 of the serial port.

Pins 11 and 12 of the MAX232 to pins 7 and 8 of the serial port. This gets the TTL signals out very neatly, BUT it means that if you wish to connect via a cable, you MUST use a home made one that only carries Rx, Tx and Gnd.





Bluetooth module wedged into a small project box and a serial port glued in.



Powered up and connected via Bluetooth to the Linx 10 windows 8.1 tablet running the 3.3.2 configurator.



Works perfectly. Can't wait to get it all back into the car.

View user's profile Send private message
Reply with quote
Post  
You did it! brilliant, clean job!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
It was a long wait but well worth it. I think the Windows 8.1 platform on the 10" screen will give me more scope to mess around than with an app on a 5" Android phone screen... and for the bargain price of 180 including the Bluetooth adaptor, case, 9 pin plug and the tablet.

The laptop is now redundant and has been sold Razz

View user's profile Send private message
Reply with quote
Post  
which device are you using? I was looking at the Lenovo Yoga 2 for showcasing the new RaceCapture app (and future megajolt apps)


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
It's a Linx 10. Only just come out over here. Seems to have good reviews so far.

View user's profile Send private message
Display posts from previous:
Reply to topic Page 7 of 7
Goto page Previous  1, 2, 3, 4, 5, 6, 7
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum