RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
My unit cannot initialize its wifi
Author Message
Reply with quote
Post My unit cannot initialize its wifi 
Im running the MacOS 1.12.1 RaceCapture app to connect to my RaceCapture Track (Rev E) unit which is connecting over USB without issue. However, any configuration which includes the WiFi unit turned on results in errors. I continue to see in my logs, over and over again:


[ESP8266 Driver] Checking WiFi Device...
[ESP8266 Driver] Initializing Wifi
[at] Command timed out
[esp8266] Init failed with msg: Soft reset failed.
[ESP8266 Driver] Too many failures.  Resetting...
[ESP8266 Driver] Initialization failed

I've first experienced the bug with 2.12, then updated to 2.13 and still see the issue.
I've also tried brentp's version of 2.13 listed here:
My log is attached from a recent boot of the RaceCapture_Track_2.13.0-1-g9dd3a25 firmware.

I can see in the code in esp8266.c that Im hitting the 5sec timeout when sending the AT+RST command.
My board is a RaceCapture Track, Rev E unit.

I've also confirmed on the board that the ESP8266 module is getting ground and 3.3v, and that the unit has no water damage or smokey smell. Im beginning to wonder if I don't have a bad module and may consider ordering a new on and soldering onto the board myself if we can't find an issue in the software.

There are two more issues I can reliably reproduce:

1.) The MacOS app, when updating the firmware has an error: 'NoneType' object has no attribute 'close'. I've seen this mentioned elsewhere in the forums. This happens at the end of every firmware flash. I did try switching over to the Windows app to flash firmware, but that gave me a different error: "Failed to load firmware. Unable to locate bootloader." Im not sure if these are related issues or not. My hardware doesn't reset on its own after a flash, I have to power-cycle it.

2.) It appears that Im unable to flash older versions of the firmware to the device. No matter what I flash with the MacOS app I still see RaceCapture Track / 2.13.0 in the upper righthand corner when the configuration is read. I've tried 2.10, 2.12, etc.

Please let me know what information I can provide, Id love to help get these issue resolved.

View user's profile Send private message
Reply with quote
Hi, thanks for posting. Good diagnosis; it seems that the WiFi module is not responding, even with the latest 2.12.0 released firmware.

Ping us at [email protected] and we can help further. We'll get you sorted out.

View user's profile Send private message Send e-mail
Reply with quote
I hate posts that appear in searches that never get a resolution, so I have good news: I was able to fix my module, the wifi chip on the board had gone bad.

I was able to buy a new wifi module from amazon for ~$10. The installation was a bit tricky, needed a soldering heat gun, a small scale soldering iron, and a microscope (because Im blind, heh), but I was able to install the module in around 45 minutes.

Crossed my fingers, booted it up, and everything works great.

View user's profile Send private message
Reply with quote
Good job fixing it! Enjoy your RaceCapture system!

Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum