RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
2.13.5: "Timeout waiting for setCanChanCfg" error
Author Message
Reply with quote
Post 2.13.5: "Timeout waiting for setCanChanCfg" error 
Good afternoon,

I have a RaceCapture/Track MK1, which I just flashed to 2.13.5.

Using the RaceCapture app on my phone (iPhone 8+, iOS 11.4), I connected to the RC's WiFi and noticed that the Dashboard was blank (it should've been showing RPM, throttle, steering, LF Wheel, Oil Temp, and Water Temp.

Then I realized that all of my CAN bus mappings were gone. This was a minor annoyance, but I'll live. (The firmware update advises you to save your configuration - but it _doesn't_ say that you'll lose your current configuration.)

I went to the "CAN Mapping" setup page and added the presets for the E46 BMW. When I tapped the "Write" button, the progress bar got a little more than halfway across and then stalled. A few seconds later, an error panel appeared:

- "Error writing" in the upper left corner
- In the center of the panel:

Could not write configuration
Timeout waiting for setCanChanCfg

I tried multiple times, and got the same result each time. _Sometimes_, the RC's WiFi would go off the air and I would have to reconnect.

Thinking that this was maybe a problem with the WiFi networking, I then plugged the RC directly into my computer (2013 Mac Pro, macOS 10.13.5) and ran the desktop app and tried to apply the CAN mappings over the USB connect. I was hoping this would work; but unfortunately I see the same symptom: progress bar gets a little more than halfway, and then the "Timeout waiting for setCanChanCfg" error.

I _was_ able to load my previously saved configuration (.rcp file) and then successfully write it out to the RC. However, I'm going to be at the track tomorrow and won't have my computer there, so I need to be able to trust that I can make changes using the phone app and save them. Right now I'm not confident.

Since I have an event tomorrow and I was looking forward to figuring out how the RC worked in actual use, I'm going to reflash it to 2.12.0 (since 2.13.0 didn't work for me). However, I will be happy to do any re-testing using 2.13.5 on Monday and help figure out why this might be failing.

(Side note: the beta firmware downloads list 2.13.0 for the RC/Track, which was a little confusing and I almost missed the 2.13.5 download.)

View user's profile Send private message
Reply with quote
>bump< :-)

View user's profile Send private message
Reply with quote

Can you post the configuration you're trying to load here to see if we can reproduce the issue? We'll see if we can track it down. Thank you!

Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Sorry about the lag! I believe that the attached RCP file is the one that it was trying to load. If you can't repro using this, please let me know and I'll get the current configuration off my RC/T and post that.

View user's profile Send private message
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum