firmware upgrade problems

Information and announcements on updates to the Megajolt firmware and PC software

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
Posts: 10
Joined: Fri Oct 06, 2006 7:26 pm

firmware upgrade problems

Post by peter »

Hi I am trying to upgrade the controller firmware so that i can calibrate the TPS and have switchable maps
however when I put in the command >hc08sprg etc I get a message saying this is not a valid win32 application am I doing something very stupid. Help please if anyone can


Posts: 65
Joined: Mon Dec 18, 2006 10:54 am
Location: Mid North South Australia

Post by aarc240 »

Go to ... ware_image
and follow all the instructions (including the second sentence).

If you don't get a command screen (like a DOS screen) then substitute 'CMD.EXE' for the 'cmd' in the above instructions.

The response you have received indicates that you tried running hc08sprg etc direct from within the Run dialog box (which DOES expect any command to be a win32 application).

Posts: 10
Joined: Fri Oct 06, 2006 7:26 pm

Firmware upgrade

Post by peter »

Thanks for the reply I am making progress slowly and learning lots as I go. The problem I have now is that I get the message . Can't open input file mjlJunior_V3.2.1.s19 After I have entered the command >hc08sprg etc

The usual plea for help goes out again

Thanks peter

Site Admin
Posts: 6280
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »


The program is saying that it can't find the file you're specifying in the command.

Is the MJLJ firmware image (.s19 file) in the same directory as where you're running the program? Are you typing the name exactly?

Code: Select all

> hc08sprg.exe COM1 mjlJunior_V3.2.1.s19
*Sometimes* windows will munge the filename and the firmware image might have ".txt" tacked onto the end. If you enter the command "dir" in the command window it will show you the names of the files in the current directory. Try this, and make sure the firmware image filename is what you expect. This is also good for double-checking your spelling.

Let us know how you work out,
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Posts: 10
Joined: Fri Oct 06, 2006 7:26 pm

Post by peter »

Hi sorry I have not got back sooner.Yes the file had a txt extension .Once I had this info it all went according to plan. V3.2.1.all seems to run on Win95 ok, it is alittle slow at times but so is the bloke pushing the buttons.Next job is to wire up switch to change maps.

Many thanks again


Andy Hill
Posts: 3
Joined: Mon Jul 31, 2006 4:37 pm

Post by Andy Hill »

I'm having problems upgrading

I can get to DOS and have real comport (com 1) set as 9600,n,8,1,n

I run the loader program and it just sits and waits at the ACK

When I turn on the ignition (pwr) I get received 0x80 and the loader suggest try single wire.

Yet when I use

Hc08sprg com1:S mjljunior_V3.2.1.s19

it won;t recognizes the S

Post Reply