RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
TPS to MAP hardware conversion
Author Message
Reply with quote
Post TPS to MAP hardware conversion 
HI

I have a pre-assembled TPS MJLV4 and am converting to MAP; have installed the map sensor the two capacitors and the resistor in the MAP section of the board and have removed R3 from the TPS section of the board to disable TPS.

The problem i have is that when i go into the configurator set the controller type to MAP the gauge sits on 0 KPa and won't move if i apply vacuum or pressure. I have attempted to reflash the controller according to the instructions but my Vista PC doesn't recognise the command.

Some help here would be great

Cheers

View user's profile Send private message
Reply with quote
Post  
Hi Booton,

Yes, reflashing your controller will get the calibration table back to "MAP Sensor" mode.

Here are some instructions for flashing the controller:
http://www.autosportlabs.net/MJLJ_Firmware_update

Make sure you are using this firmware:
http://www.autosportlabs.net/asl_dist/mjlj/mjlJunior_firmware_V4.0.2.zip


You will need to do this from the command line. Make sure the configuration software is not running. What exact errors are you seeing when flashing the controller?



Last edited by brentp on Thu Jan 20, 2011 4:58 pm; edited 1 time in total

_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Also, you'll want to check your MAP sensor installation. Make sure the sensor is installed exactly the way it's shown in the assembly pictures; if it's mounted upside down it will not work correctly.

Let us know what you find out!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Hi Brent

Thanks for getting back to me.
The MAP installation looks good but i still can't reflash the unit.
After following the instructions i get the following message: can't open input file mjlJunior_V4.0.2.s19
If i run : C:\mjlJunior_firmware_V4.0.2\hco8sprg.exe COM11 then things look kind of promising but no reflash.
I have tried deleting and re-downloading the .s19 file but no joy either.
The unit is OFF and the configuration software is not open


Is there any way of manually inputting the MAP sensor calibration; unfortunately I'm not all that computer savvy.

Cheers
Nick

View user's profile Send private message
Reply with quote
Post  
You should put all of the files in the same directory.

for example,

c:\megajolt

place hco8sprg.exe and mjlJunior_V4.0.2.s19 into that directory.

then, when you open a command prompt, type:

cd c:\megajolt

which will place you in that directory.

Then type

hc08sprg.exe COM11 mjlJunior_V4.0.2.s19

when it says " waiting..."

then apply power to the megajolt.

You should see the flashing progress on the screen similar to how the instructions show.

Let us know what you find out!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Hi Brent
thanks for the crystal clear tech support. Unit is reflashed and MAP sensor is looking good. If I had to guess I would have put my money on my soldering skills being deficient.
Much appreciated.
Cheers Nick

View user's profile Send private message
Reply with quote
Post  
Ok so now I need to convert back to TPS control; what do I need to do to effect the change?

View user's profile Send private message
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum