RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Extended Can not working for me..
Author Message
Reply with quote
Post Extended Can not working for me.. 
Hi guys,

I am having a issue with the lua can bus function. It works perfect with 2.0 a protocol, but as soon as I switch to extended mode it doesnt transmit the correct ID. It sends 0x00 no matter what I do.

I have to be able to transmit in 2.0b mode since it is speaking with a propriatary protocol so therefore I can t use standard protocol.

Any other have same issues? I am running newest firmware and App.

Best regards

Mads

View user's profile Send private message
Reply with quote
Post  
Hi Mads,

We will double check the extended IDs and get back to you.

Thanks,
Brent


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Hi,

we will have this fixed in the upcoming 2.8.4 release, available next week.

-Brent


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Perfect Thank you Smile

View user's profile Send private message
Reply with quote
Post  
Was this fixed? I'm having issues reading data after an extended ID transmission. I get a successful write but rxCAN always returns a nil id. I don't have VehicleSpy hooked up to see what is actually going out on the line.

View user's profile Send private message
Reply with quote
Post  
Hi, we are targeting this fix for 2.9.0 firmware, along with a bunch of other fixes and improvements, but we have made a beta 2.8.7 firmware that has only this fix we're testing. If you're willing to test it out, we can make it available.


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I'm in a great position to test it. My script is written to write and read 29-bit; I have external application code, other hardware, and Vehicle Spy to test.

View user's profile Send private message
Reply with quote
Post  
2.8.7 firmware released here, which should fix your CAN ID issue:

https://www.autosportlabs.com/2-8-7-firmware-available-for-mk2-mk1-development-has-moved/


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I'll test it out as soon as I can. My tests will be through LUA custom block reads over extended CAN.

View user's profile Send private message
Reply with quote
Post  
I can confirm that 29-bit CAN is indeed working on 2.8.7+.

View user's profile Send private message
Reply with quote
Post  
Thanks for the update!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum