RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Odd dashboard 'analog' gauge issue
Author Message
Reply with quote
Post Odd dashboard 'analog' gauge issue 
Bug:

I just hooked up a 14point7 Spartan WB02 sensor to AN1, and adjusted the input scaling to read AFR from 10 to 20 (over the 0-5V range).

Adding a gauge to the dashboard works fine, except that the 'analog' portion of the gauge is always pinned, almost as if it was still assuming a 0-5 value, even though the gauge is reading 10-20. This also shows up when attempting to set the colour thresholds, as the available ranges for each run from 0-5, rather than from 10-20.

The digital value reads out 'correctly' (the numbers change appropriately with the input voltage), so the actual input seems to be working correctly; the gauge is (probably?) just not looking at the post-scaled values.

Feature:

Related to AFR inputs; it would be nice to be able to toggle between AFR and lambda from the same input without having to reset the scaling.

View user's profile Send private message
Reply with quote
Post  
Hi Mike, try checking the min / max values on the channel configuration (press the gear icon next to the channel name). You'll be able to set the min/max values which will correctly scale the gauge.

Let us know if that works for you!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
brentp wrote:
Hi Mike, try checking the min / max values on the channel configuration (press the gear icon next to the channel name). You'll be able to set the min/max values which will correctly scale the gauge.

Let us know if that works for you!


I was a bit confused by not being able to set the min value first (it clamps to the max rather than adjusting the max), but once my tired brain realized I should try the max field, it seems to DTRT.

View user's profile Send private message
Reply with quote
Post  
Great - glad you figured it out, and thanks for the update!


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum