RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Accelerometer smoothing
Author Message
Reply with quote
Post Accelerometer smoothing 
I finally got my car on the track, and got a chance to look at some of the data from my MK3. I'm looking at my data on RaceRender, and the G-plot constantly shakes all over the place. I'm able to see trends to a degree, but so much shaking that it's essentially impossible to see what sort of Gs I'm actually getting. Is that something wrong with the unit, or is there a way of programming some sort of smoothing to dampen it out? I can't find a control for smoothing if it exists. I would appreciate any assistance on this.

I am also having the same issues as above with the pitch and roll.

This is the first time I've had a chance to use the unit since I bought it brand new from Autosports Labs early last year. I already had to send it back for repairs to the WiFi. I hope it doesn't have a problem with the accelerometer system too. If it does though, I would like to get it fixed. I'll be happy to send you a log file if that will help you to see what I'm looking at.



Thanks.

View user's profile Send private message
Reply with quote
Post  
Isn't there someone out there that can help me with this? As it is, some of the most important features of this unit are all but useless. I would like to determine what is the problem and get the unit working properly. I would appreciate some help. anyone????? i should not be showing continuous jittery swings of back and forth between + and - 1.9G in all 3 axis.

I just thought of something, and maybe someone could comment on this. There is no guidance I found for what to mount the MK3 to (only orientation, nothing more). I have it mounted to a relatively rigid sheet metal panel which is rigidly attached to the chassis of the car (a flat horizontal panel that is part of the driveshaft tunnel). This is a prototype purpose built car with a stiff chassis and stiff suspension, so the chassis feels everything the car does. Is it possible or likely that the jittering is because of the sensitivity of the unit -- it is measuring every minute vibration and bump the car encounters? if so, would it help if I mounted the unit via velcro to a rubber pad mounted to the same sheet metal?? Or would that possibly make the problem worse due to the rebound and reverberation affect of the padding? I can see it going both ways. Is there possibly a better way to mount it than the current mount or the above idea to mount it?

View user's profile Send private message
Reply with quote
Post  
Hi, it sounds like you are dealing with some vibration of the unit.

Can you put it in a different test environment, possibly with some additional cushioning, so you can test and see the difference? if you can get some better readings, then perhaps you can mount it with some rubber isolation in the main installation.

Overall, it's best to reduce noise and vibration at the source before you try to smooth the data.

At the moment, there is a degree of accelerometer smoothing that is set within the configuration file that is not exposed in the UI. We fixed it to a moderate amount of smoothing at the moment, until we make it exposed in the setup UI.


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Thanks. I figured that out as a strong potential after I sent the message. You might consider putting that recommendation in the mounting instructions. I'm not sure why I didn't think of it while mounting it or initially when looking at the problem. Thanks.

View user's profile Send private message
Reply with quote
Post  
Thanks for the reply. So, to clarify - did you add some rubber isolation or dampening and did it seem to help?


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I added an isolation dampener, but I haven't had a chance to test it yet. Hopefully next weekend, but depends on the weather. I know that with my G2X, the instructions specifically recommended using an isolation dampener, and i never had a problem with it in my Mustang. That was about 10 years ago, and forgot about that when installing the MK3, and I didn't see anything in the MK3 install instructions to that affect, so I didn't think about it.

View user's profile Send private message
Reply with quote
Post  
One idea in the meantime is to pull RCP and place it on the carpeted floor of your regular car, and go for a test drive. How does the accelerometer look under those tests?


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
can i do that with just the laptop hooked up for power? If so, that's certainly worth a try. If not, I'll have to pass. wring it to the car would be more work than I want to do right now - especially since I don't have a connector to fit the unit other than the one that came with it, so I would have to find where I can buy one along with the pig tails or pins.

I have an old problem returned or had gotten better and now appears to be here to stay. I'll post it in a new post. I would appreciate a little help on that - getting my MK3 to trigger the GoPro 3 to start and stop recording, and WiFi connectivity with my Galaxy s6.

View user's profile Send private message
Reply with quote
Post  
You have a variety of options:

If you have a USB charger in the car, you can power RCP just with that, using the USB cable. You can log to SD card, or log to the connected app (laptop, tablet, or phone).


_________________
Brent Picasso
Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Great. Thanks. I'll give that a try and see how it works out. I didn't realize the unit would do more than communicate with my laptop or phone off the USB.

View user's profile Send private message
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum