Motec C185 Integration Troubles

Q&A for AnalogX Analog to CAN interface. <a href="https://wiki.autosportlabs.com/AnalogX">Installation and Operation Guide</a>
Post Reply
nightatthegarage
Posts: 2
Joined: Thu Apr 26, 2018 12:24 am
Location: Bakersfield, California

Motec C185 Integration Troubles

Post by nightatthegarage »

I hope all is well.

I am attempting to integrate an AnalogX with a Motec C185 Dash on hand. Any insight or direction would be greatly appreciated. I believe I have a comms setup issue on hand. The "received" can data values are fixed and unrealistic voltages(all 4 inputs are different) and do not vary even if I disconnect the 6 pin connector removing all the analog sensors from the equation. These values are not the default values set by the Motec software ie. in case a sensor is missing. The defaults are all set to zero. No can-bus errors are present in the Motec. I have included a URL to pdf containing screenshots of Motec settings.

Hardware Checks Performed:
-Motec Hardware/loom in proper working order, confirmed by using can bus channel to receive IR Temp can data
-AnalogX Baud rate set to 1M (jumper removed and verified the bridge is open with a multimeter)
-AnalogX default termination is intact
-12v supply at AnalogX w/ good ground
-5v reference out of AnalogX
-With 6pin connector discounted 0.2v at signal pins 1-4 (using grd at 6pin)
-6pin connected, measure at 6pin, each analog pin sensor voltage is appropriate (ie manually referencing to sensor calibration curves each is within reason)


Programming Checks:
-Motec Communications setup Mode: "CAN"
-Motec Communication setup Parameters: "receive message", "fixed binary", "Wordswap"(tried "normal"), "receive timeout"=2200ms, "Extended Address"=000E4600
-Motec Channel Settings: Input1=offset 0, length 2...Input2=offset 2, length 2...Input3=offset 4, length 2...Input4=offset 6, length 2.
-Motec settings: multiplier=1, divisor=1, adder=0, (note changing these settings does change the displayed channel data but the data is still fixed and unrealistic voltages, no change with analog sensors connected/disconnected.[/b]

Motec Settings Screenshots:
https://drive.google.com/open?id=1kmfDE ... rNV75Ty-Gm

ferg
Posts: 36
Joined: Mon Dec 03, 2018 7:56 pm
Location: Paso Robles, California
Contact:

Post by ferg »

I'm a MoTeC dealer and you're in my neck of the woods. Feel free to contact me directly for help.

My guess, I think the base address for the data message should be E46020 (or maybe E46014 if the +20 is a decimal value). See this page on the Wiki:

https://wiki.autosportlabs.com/AnalogX#CAN_base_ID

I would use the MoTeC "CAN Inspector" software with your C185 to verify there are messages (and at what address) on the CAN bus. That software is available in the Utilities download from MoTeC's software download page:

https://www.motec.com.au/software/latestreleases/
David Ferguson
Veracity Racing Data
Autosport Labs Preferred Dealer
https://veracitydata.com

nightatthegarage
Posts: 2
Joined: Thu Apr 26, 2018 12:24 am
Location: Bakersfield, California

Post by nightatthegarage »

ferg wrote:I'm a MoTeC dealer and you're in my neck of the woods. Feel free to contact me directly for help.

My guess, I think the base address for the data message should be E46020 (or maybe E46014 if the +20 is a decimal value). See this page on the Wiki:

https://wiki.autosportlabs.com/AnalogX#CAN_base_ID

I would use the MoTeC "CAN Inspector" software with your C185 to verify there are messages (and at what address) on the CAN bus. That software is available in the utility download from MoTeC's software download page:

https://www.motec.com.au/software/latestreleases/
Thanks for the direction! The Motec "CAN inspector" saved the day. I made an adapter to hook in my Peak PCAN interface but the software interface was giving me hell.

The "CAN inspector" revealed the base address to be "E4614 (not E46014) or 935444 in decimal. Which surprised me since the Wiki documentation doesn't show E4614 (935444 decimal) as an option for the base address regardless of the jumper configuration.
I have been slowly working myself in the Motec world as of late. I am headed to NC next week for Motec training. Thanks for the insight.

ferg
Posts: 36
Joined: Mon Dec 03, 2018 7:56 pm
Location: Paso Robles, California
Contact:

Post by ferg »

oops I added a zero in there. On the wiki, they show the base address as E4600, but the messages with the the data are sent to base + 20 (dec), or E4614 as you discovered.

Note that you can transmit a message to 0xE4603 (Base + 3 if I did the math right this time) with the desired transmission rate.

You can receive the current sample rate and version info by a message on CAN ID 0xE4602.

Glad you got it sorted.
David Ferguson
Veracity Racing Data
Autosport Labs Preferred Dealer
https://veracitydata.com

brentp
Site Admin
Posts: 5925
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »

Thanks Ferg for helping, and glad you got it sorted out!
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Post Reply