RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Race Capture Pro Mk3 will not connect to Race Capture App
Author Message
Reply with quote
Post Race Capture Pro Mk3 will not connect to Race Capture App 
I was attempting to update both the app and the firmware today. I think though I have only succeeded in breaking the RCPmk3. Now it will not connect to the race capture app. The green power light comes on and the sd card light flashes yellow very fast. Other than that, nothing. I have checked to make sure that the unit is not stuck in bootloader by verifying the button is not depressed. I do not have an SD card installed as we do not use this unit for data logging.

If I have somehow interrupted or loaded bad/wrong firmware, corrupted the bootloader, or some other coding no no, is it possible to some how manually reset the factory start up sequence?

Can I send the unit in for this?

Any help would be greatly appreciated. I really do not want to buy another unit if this one can be salvaged.

View user's profile Send private message
Reply with quote
Post  
I noticed the same last night- MK3 and a Fire tablet both on the latest app & firmware. Tablet would not connect to the RCP in the dashboard page when it first opened. I then went into setup, read config, and it connected.

Haven't had a chance to diagnose any further.

View user's profile Send private message
Reply with quote
Post  
Hi,

It sounds like the unit did not complete the firmware upgrade process. This is easy to fix - just re-do the firmware update process:
https://wiki.autosportlabs.com/RaceCapturePro_How_To_Update_Firmware

The flashing orange light means the system is in bootloader mode - ready to receive new firmware over USB.

Ultimately, the system is fairly "un-brickable" - by design. Please let us know it goes on your next attempt.

Thanks,


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Thank you for the reply Brent.

Unfortunately the Race Capture does not connect to the app via the USB. The app attempts to connect but alternates "Searching Com 3" and "Connecting..." thus I cannot even get to a point where I can do a firmware update. My PC senses that a device has been connected via USB but beyond that there appears to be no communication.

Do you have any suggestions? I would like to get this resolved so that this unit can be used for future races.

Alex

View user's profile Send private message
Reply with quote
Post  
Did you follow these steps listed as the "Alternate Method"

While holding down the button on RaceCapture/Pro, power it up by plugging in to USB.
You should observe a rapidly flashing LED on the unit: this means it's in bootloader mode.
Start the app. Note, it will not be able to connect - this is expected.
Navigate to Setup.
Load a previously saved configuration file.
Navigate to the firmware update view, then follow the process to update firmware.


_________________
David Ferguson
Veracity Racing Data
Autosport Labs Preferred Dealer
https://veracitydata.com
View user's profile Send private message Visit poster's website
Reply with quote
Post  
Well the alternative method took care of it! The unit is back up and running. Thank you!

View user's profile Send private message
Reply with quote
Post  
Glad you figured it out!


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum