RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Firmware Update: "Waiting for device to appear on USB..
Author Message
Reply with quote
Post Firmware Update: "Waiting for device to appear on USB.. 
I can't seem to get past this prompt. The computer "chirps" as though something being plugged into the USB, but the dots just keep on coming.

Anyone else have any issues getting the v2 Firmware installed?

View user's profile Send private message
Reply with quote
Post Firmware Update 
Hi,

I met the same problem under WIN7 x64 with the USBdrivers V2(said to use for firmware 1.2 or higher on the page) installed,but I didn't fix it. I tried the Linux way to flasher it into the device and no problems showed up. You could have a try.

View user's profile Send private message
Reply with quote
Post  
Had the same problem with Windows 7 x64. Wound up doing the upgrade via Linux.

View user's profile Send private message
Reply with quote
Post Firmware Update 
Anyone have any resolution to the v2 FW update outside of using Linux?

I have tried on Windows 7 x64 (then I saw this post) and have now also tried Windows Vista, but had the same results - all three lights green just with the "waiting for device to appear on USB" prompt.

View user's profile Send private message
Reply with quote
Post Re: Firmware Update 
Senordan wrote:
Anyone have any resolution to the v2 FW update outside of using Linux?

I upgraded to the v2 firmware with XP successfully with no issues, but was not able to connect to the v2 app and ended up going with linux, given that XP is EOL.

View user's profile Send private message
Reply with quote
Post  
Hi Senordan,

What is the version of your firmware before upgrading? There was a change in the USB device ID in v 1.2.x firmware that fixed a key problem around writing the bootloader.

When you go through the steps in the firmware update .bat file, and it asks "is this your first time.." - say yes - this will cause the bootloader drivers to be installed.

If you're still stuck, let us know and we can help you walk through it.


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post Me too 
I'm on a Windows 7 box and am also having the same issue where I can't update the firmware. I press the button, plug in, wait for 3 lights, and the response is waiting for USB...............

The control panel shows it to be an input device. Looks like others have had the same problem. Is the only solution to this to use XP or Linux?

I've tried using the new firmware and the old firmware packages and also tried installing the bootloader.

View user's profile Send private message
Reply with quote
Post  
Hi drKorf,

if you put RCP into bootloader mode (power up while holding down front button) what do you see in windows device manager?


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
It thinks it's an input device.

View user's profile Send private message
Reply with quote
Post  
can you post a screenshot of device manager when it's in bootloader mode? if the bootloader is properly activated it should show something under 'libusb-win32' or similar.

If not, then we may need to manually install the bootloader drivers.


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I just ran into this same problem and figured I'd post my solution in case it helps others. When in bootloader mode the RCP kept showing up as "USB Input Device" in Windows device manager. I even used USBDView to uninstall every USB device and driver on my system.

I was finally able to make it work by connecting in bootloader mode and then manually installing the bootloader drivers at the same time. This only worked if the RCP was connected in bootloader mode while installing the drivers. If I installed the drivers manually before connecting it never would work.

View user's profile Send private message
Reply with quote
Post  
Thank you; this is a really important tip. We'll update our MK1 firmware instructions accordingly.

The latest MK1 firmware is fairly solidly tested and will be available as soon as we write a blog post and update some docs. This will put MK1 in parity with MK2 firmware release. Even though we'll call it 'beta' it will be better and more stable than the current released version of MK1 firmware. We are excited to release it!


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Update: V2 firmware for MK1 announced here http://www.autosportlabs.org/viewtopic.php?t=4323 Enjoy!


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum