RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Unable to install drivers, Windows 8.1
Author Message
Reply with quote
Post Unable to install drivers, Windows 8.1 
I've been trying to upgrade my original RCP to the latest firmware and app on a Windows 8.1 machine. I've tried installing the drivers a few times with the same result. "Windows could not find driver software for your device"

A couple things of note:
1) I can see the RCP in the device manager with no drivers
2) Tried updating the driver through the device manager by manually pointing it to the driver files.
3) I followed the procedure to allow unsigned drivers
4) Everything on the RCP is, as delivered, from the original Indiegogo campaign.

My exposure to windows 8 is limited so maybe there is an alternate procedure?

Thanks, Andy

View user's profile Send private message
Reply with quote
Post  
Hi,

Thanks for the note. Are you running the original MK1 firmware, or have you updated it yet? Updating it to the latest firmware will be the first thing to do if you want to run it with the new app.

If you need help updating the firmware let us know and we can walk you through it.

Thanks,


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I'm trying to update the firmware but I cant get Windows to recognize the drivers in order to do so. I'm basically stuck after simply plugging it in to the USB port.

View user's profile Send private message
Reply with quote
Post  
Hi,

If you hold down the button and then plug it in to USB, what shows up in device manager? Do you see an 'unrecognized device' or an entry under libusb.. showing something like "Autosport Labs bootloader"?

Answering this question will lead us to whether we need to install the bootloader drivers, which will allow firmware to be programmed.


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I had something more comprehensive typed up but Firefox decided to crash. Basically I tried this again and somehow got a different result. When I plugged it in with the button pressed no new devices showed up. I get three indicator lights on the unit and the laptop gives audible feedback that a usb device has been plugged in.

View user's profile Send private message
Reply with quote
Post  
Got it. So after doing that, what shows up in Device Manager?


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Here is a screenshot:
http://i82.photobucket.com/albums/j266/pfotenhauer/rcp_device_manager_zps523eda88.jpg

Also, I don't know if it matters but when I plug it in without the button pressed it shows up in the device manager under "Other devices" as "RaceCapture/Pro" with no drivers installed. This must have been where I was trying to install the drivers without success. I thought I was doing this with the button pressed but apparently not. BTW, thanks for the help!

View user's profile Send private message
Reply with quote
Post  
It looks like it doesn't see the bootloader driver.

Try this:

download the flasher utility from here:
http://www.autosportlabs.net/RaceCapturePro_Downloads#Firmware_update_utility

unzip it and then run 'bootloader_drivers.exe' from the archive. These will install the drivers needed for bootloader mode.

Then, hold down the button while plugging RCP into the computer.

If you check device manager, you should see see an entry under 'libusb'. If you see this, you can use the flasher utility to flash the latest version of the firmware.

Let us know how it goes!


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I managed to get somewhere but not very far. After following the procedure to allow unsigned drivers, I was able to successfully run bootloader_driver.exe. When I plug it in with the button pressed I still see nothing in the device manager. When I plug it without the button pressed I see the "libusb" entry. So, something happened but I'm not sure what.

View user's profile Send private message
Reply with quote
Post  
Sorry if this is a lame response, but can you do this first upgrade on a non windows 8.1 PC? There was a conflict with early version of the firmware where the bootloader and main firmware shared the same VID and PID; this caused confusion with some instances of windows.

once the firmware is upgraded to 1.2.x and later, the PID changed on the main firmware and the problem basically goes away - since the bootloader show up under it's own PID, and the firmware under a different one.

Keep us posted; at the very least you can send it in and we'll do that upgrade for you. Thanks!


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
* email sent as well.


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post I'm having the same issue 
windows 8.1 pro, I plug in the RC. device manager shows RaceCapture/Pro with a yellow question mark. I downloaded the USB drivers, extracted them, open the RC properties and try to update the drivers by telling it to look in the directory where the drivers are. It says the driver are not in that folder.
I tried it with my W7 and same result.
Help

View user's profile Send private message Send e-mail
Reply with quote
Post  
Hi,

I think we helped you separately via email. ping us again if you're still having problems. Thanks!


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum