Sparks but no rpm read out in software

EDIS and Megajolt installation related topics. Be sure to review the <a href="">Vehicle installation guide</a>

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
Posts: 2
Joined: Sat Aug 01, 2015 11:06 pm

Sparks but no rpm read out in software

Post by Lewis.27 »

Hi, I've just finished instaling a megajolt v2 running edis 4.

I have a spark on all four plugs but the rpm gauge in the software indicates 0 rpm whilst cranking, it sparks Wether the megajolt is plugged in or not so I'm sure the wiring for the edis is correct.

I have wired the pip and saw wires the correct way around as per the plug pinout diagram that I found on this site, I've also tried swapping the pip and saw wires around to see if the was the problem.

I've tried swapping the vr sensor wires around but it will only spark with them connected around one way, I've also tried a different edis module.

Im getting 12v at the pip pin on the edis and I'm getting the same at the pip pin on the megajolt plug.

Whilst cranking it's fluctuating between 4 and 2.5v at both ends (edis and megajolt).

Any ideas as to what could be causing the lack of rpm readout in the software would be much appreciated.

Thanks, Lewis

Site Admin
Posts: 5986
Joined: Wed Jan 24, 2007 6:36 am

Post by brentp »


Assuming the software can read / write the ignition configuration, the key is the PIP signal to show RPM.

See this guide for verifying various signals ... xYb0Q/edit

Let us know what you find out!
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter

Posts: 2
Joined: Sat Aug 01, 2015 11:06 pm

Post by Lewis.27 »

Thanks for the reply.

We started the car and it seems that the engine wasnt turning over fast enough for the software to show an rpm reading.

Once the car started we could see an rpm readout.

The only issue we have now is an erratic rpm readout as when the car is idling the gauge jumps around a bit and causes a misfire.

Im hoping that shielding the vr sensor wiring will fix this.


Post Reply