RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 2
Goto page 1, 2  Next
OpenGL 2.0 needed running 2.1 version and Kivy sees 1.1?
Author Message
Reply with quote
Post OpenGL 2.0 needed running 2.1 version and Kivy sees 1.1? 
As the title explains Iím running openGL2.1 and race capture software 1.8.0 think Iím running openGL 1.1 on my widows 7 laptop.

View user's profile Send private message
Reply with quote
Post  
If the app cannot detect the OpenGL version it needs, it will show this error. Best bet is to update the video drivers, if possible, or, use a computer with the graphics support required.


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Ok thatís fine and all but we are not going to carry various type of laptop as for software unable to detect drivers on professional used laptops. We are not into game play and we install data accusation equipment on a daily base having no problems except for one so we kindly ask to investigate your software and maybe step thing down a bit on graphics if needed. Thanks in davance.

View user's profile Send private message
Reply with quote
Post  
We understand your concern. Unfortunately, the needed OpenGL support is a requirement for the software we use based on the core technology we use. If it is complaining, then we do not have many options.

Android, iOS and Windows 10 computers should avoid these compatibility issues with older drivers.

Thank you, again!


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Forgot to mention we can run up to v1.4.2 software. Again the newer version software detects a opengl1.1 while running a 2.1 so looks like itís a bug in the software that dos this running windows 7.

View user's profile Send private message
Reply with quote
Post  
Other question can we still use v1.4.2 software to configure the RaceCapture/Pro MK3, just sold the last MK2 and need to order new ones soon.

View user's profile Send private message
Reply with quote
Post  
After version 1.4.2 we switched to a new version of the app framework, which is likely why it has a more stringent requirement.

1.4.2 won't work with the new MK3 systems as protocols have changed and new features have been added.


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
I have the same issue. I'm running a Lenovo T410 with W7 and Intel integrated video. I updated to the latest driver, and still get the same message. Would have been nice to use a laptop with this thing.

View user's profile Send private message
Reply with quote
Post  
I had the same problem, and solved it on my end.

The issue is a known fault in Kivy, and has still not been solved: https://github.com/kivy/kivy/issues/3576 There is however a workaround:

The solution is to add two lines to the code. I downloaded the code from github, installed python and kivy, made the following changes to main.py, and now it works:

Code:
if __name__ == '__main__':
    import logging
    import argparse
    from kivy import Config
    Config.set('graphics', 'multisamples', '0')
    import kivy


Not being very familiar with github, I would rather not wade in and make the changes there, hopefully a dev will do it for us.

View user's profile Send private message
Reply with quote
Post  
This is great, thank you, we'll be sure to add it to the next release ASAP.

Tracking here:
https://github.com/autosportlabs/RaceCapture_App/issues/1465


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Brent - having the same issue on the latest version of the Windows app running Win 8.1. Running the most up to date graphics drivers.

Best to use Slowie's fix still?

View user's profile Send private message
Reply with quote
Post  
Hi - that fix will be in the 1.12.0, beta due out next week if everything aligns correctly! Real soon now.

Thanks!


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Reply with quote
Post  
Thanks Brent.

I found an easier way around it - in the .kivy folder located within the "Users" folder in Win 8.1, I modified the config.ini file, under [graphics], to change the multisamples value from 2 to 0.

App launches without errors currently.

View user's profile Send private message
Reply with quote
Post  
I also tried that initially. Quite bizarrely it does not work for me, but making the change in the actual code does. And it seems that both methods should yield identical results.

View user's profile Send private message
Reply with quote
Post  
Thanks for confirming that! 1.12.0 app available in beta early this week, working on the builds right now.


_________________
Brent Picasso
CEO and Founder, Autosport Labs
Facebook | Twitter
View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 2
Goto page 1, 2  Next
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum