Serial API for V3.3.1 firmware

General Megajolt Questions and Answers

Moderators: JeffC, rdoherty, stieg, brentp

Post Reply
capri_turbo
Posts: 119
Joined: Tue Jan 10, 2006 8:17 pm
Location: North Yorkshire, UK

Serial API for V3.3.1 firmware

Post by capri_turbo »

Brent

Is there a Serial API available for the V3. as the latest seems to be 3.1 and doesn't have the "aux" listed.

The reason I ask is that I am looking at the code for an Arduino project to read the serial data. All I can find are sketches to do the V4 and I know the V3 is very different.

Thanks

Colin
Last edited by capri_turbo on Fri May 22, 2020 5:47 pm, edited 1 time in total.

capri_turbo
Posts: 119
Joined: Tue Jan 10, 2006 8:17 pm
Location: North Yorkshire, UK

Post by capri_turbo »

Can the V4 API be used as I notice the file was originally 3.3.x?
Last edited by capri_turbo on Fri May 22, 2020 5:46 pm, edited 1 time in total.

capri_turbo
Posts: 119
Joined: Tue Jan 10, 2006 8:17 pm
Location: North Yorkshire, UK

Post by capri_turbo »

I think, all I need to know is which byte and which bits contain the aux. scaled info on the serial output on the latest V3 as I have managed to get Advance to display correctly, not tested RPM yet, but that should be fine, Load is now working (different from the V4 sketch that I am modifying), but I cannot get the Aux. data yet.

capri_turbo
Posts: 119
Joined: Tue Jan 10, 2006 8:17 pm
Location: North Yorkshire, UK

Post by capri_turbo »

Can anybody please advise on this for me.

capri_turbo
Posts: 119
Joined: Tue Jan 10, 2006 8:17 pm
Location: North Yorkshire, UK

Post by capri_turbo »

Can anybody please advise me of where in the serial string the aux. data is transmitted.

Is the support for the V3 finished now?

I'm reading the V3 just fine... got Advance, RPM, Load (KPa) and user out 1 displaying useful data... I just need the aux output for the coolant temperature next, but cannot locate it...

capri_turbo
Posts: 119
Joined: Tue Jan 10, 2006 8:17 pm
Location: North Yorkshire, UK

Post by capri_turbo »

I've got this far using the $ command (0x24)

Is there a different command that brings in the aux data? I've tried S (0x53) but that doesn't seem to contain it either.

"Fan" is based on UserOut1 status as that is controlled from the aux temperature... its blank when its not running

Everything else is working just great but it's slightly frustrating that the aux data is seemingly not documented for the V3 units and nobody seems to be able to answer my question.
Attachments
MJV3_Display.jpg
MJV3_Display.jpg (68.83 KiB) Viewed 830 times

capri_turbo
Posts: 119
Joined: Tue Jan 10, 2006 8:17 pm
Location: North Yorkshire, UK

Post by capri_turbo »

With the assistance of a serial port sniffer, I think I've cracked it.

The tuning software seems to send 's' (0x73) and receives 9 bytes

By Adjusting the pot on my test board I've noted that byte 7 changes with the temperature.

Arduino re-programmed and:
Attachments
Display_working.jpg
Display_working.jpg (106.7 KiB) Viewed 799 times

Alex B
Posts: 163
Joined: Sat Aug 09, 2008 10:32 am
Location: Hegra, Norway

Post by Alex B »

If only I had half the knowledge you have about these things........

Alex

tightwad
Posts: 46
Joined: Tue Sep 10, 2013 10:11 pm

Post by tightwad »

Nice work, I have been wanting to dig in more to power a display that can be read in sunlight as I use the V4 on a 32 year old Watercraft. I'd like to include other sensor data as well, so I will be watching what you are able to accomplish.

I have done a total of 1 Arduino program...but I want to learn more!

capri_turbo
Posts: 119
Joined: Tue Jan 10, 2006 8:17 pm
Location: North Yorkshire, UK

Post by capri_turbo »

This was my first Arduino project so I'm very plesed with it... looking at RFID immobilisers and GPS stuff at the moment, but as for the Megajolt display, I don't think I'll be developing it any further as it does exactly what I intended it to do.

If you want the Arduino code, just ask here and I'll sort it out for you.

Col

Post Reply